Project

General

Profile

Actions

Bug #17910

closed

Fatal error when trying to edit an record with additionalPreviewLanguage and an deleted l18n_parent

Added by Marc Bastian Heinrichs over 16 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-12-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

[v4.1.4]
Fatal error: Cannot use string offset as an array in [...]/typo3_src-4.1.4/t3lib/class.t3lib_tceforms.php on line 2954

$tInfo is an string

patch follows

to reproduce
  • add an website language
  • set options.additionalPreviewLanguages of BE user to uid of language
  • translate a page
  • add an content element
  • translate the content element
  • deleted the org content element
  • try to edit translated content element
    (issue imported from #M6931)

Files

6931.patch (980 Bytes) 6931.patch Administrator Admin, 2007-12-12 00:02
Actions #1

Updated by Marc Bastian Heinrichs over 16 years ago

here is the patch against 4.1.4

Actions #2

Updated by Susanne Moog over 13 years ago

In current TYPO3 versions deleting only the original content element which still has a translation attached shouldn't be possible because the translated element is automatically deleted with it.
Do you still have a problem with this feature or can this report be closed?

Actions #3

Updated by Marc Bastian Heinrichs over 13 years ago

Jep, in newer TYPO3 versions the translated element is automatically deleted with the parent. So this problem can't be reproduced.
But don't you also mean checking the 2-dim array the right way doesn't hurt?

Actions #4

Updated by Susanne Moog over 13 years ago

No, of course it does not hurt. Would you mind sending your patch to the core list so it can be +1 and committed?

Actions #5

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change Id51afff4349a473f291ef50631b519942f45be13 has been pushed to the review server.
It is available at http://review.typo3.org/4734

Actions #6

Updated by Andreas Wolf almost 13 years ago

  • Status changed from Needs Feedback to Under Review
  • Target version deleted (0)
Actions #7

Updated by Andreas Wolf over 12 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Gerrit Code Review over 12 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/6210

Actions #9

Updated by Andreas Wolf over 12 years ago

  • Status changed from Under Review to Resolved
Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF