Bug #18047

Fixing docheader in the backend modules

Added by Benni Mack almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-01-24
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The new docheader in alt_doc.php is not perfect yet, also missing in the list, page and template view of the Backend. We're going to change this.

That's why we made some changes.

(issue imported from #M7262)

20080124_docheader_alt_doc.patch View (12 KB) Administrator Admin, 2008-01-24 13:59

20080129_docheader_alt_doc_db_list.diff View (42.8 KB) Administrator Admin, 2008-01-29 22:03

list view.jpg View (31.3 KB) Administrator Admin, 2008-01-30 09:00

page view.jpg View (30.7 KB) Administrator Admin, 2008-01-30 09:00

edit record-1.jpg View (20.4 KB) Administrator Admin, 2008-01-30 09:00

20080131_rfc7262.diff View (95 KB) Administrator Admin, 2008-01-31 14:49

page module header-1.jpg View (27.5 KB) Administrator Admin, 2008-01-31 15:27

list module header-1.jpg View (16.1 KB) Administrator Admin, 2008-01-31 15:27

more docheader fine tuning.png View (71 KB) Administrator Admin, 2008-02-01 14:28

fine-tuning-redundancy.jpg View (76.2 KB) Administrator Admin, 2008-02-01 14:42

20080204_rfc7262.diff View (130 KB) Administrator Admin, 2008-02-04 11:18

20080205_rfc7262_base.diff View (9.95 KB) Administrator Admin, 2008-02-05 09:59

20080205_rfc7262_func.diff View (7.84 KB) Administrator Admin, 2008-02-05 10:00

20080205_rfc7262_info.diff View (8.31 KB) Administrator Admin, 2008-02-05 10:00

20080205_rfc7262_list.diff View (43.1 KB) Administrator Admin, 2008-02-05 10:00

20080205_rfc7262_page.diff View (45.5 KB) Administrator Admin, 2008-02-05 10:00

20080205_rfc7262_perm.diff View (8.63 KB) Administrator Admin, 2008-02-05 10:00

20080205_rfc7262_template.diff View (15.7 KB) Administrator Admin, 2008-02-05 10:01

20080205_rfc7262_versioning.diff View (9.29 KB) Administrator Admin, 2008-02-05 10:01


Related issues

Related to TYPO3 Core - Feature #18148: add docheader to file -> filelist module Closed 2008-02-07
Related to TYPO3 Core - Bug #18130: Pagetree docheader not according to other docheaders Closed 2008-02-06
Related to TYPO3 Core - Bug #18150: Docheaders: Module Web > Page : No docheader when no page has been chosen Closed 2008-02-07
Related to TYPO3 Core - Bug #18151: Docheaders: Module Web > Functions : No docheader when no page has been chosen Closed 2008-02-07
Related to TYPO3 Core - Bug #18152: Docheaders: Module Web > Versioning : No docheader when no page has been chosen Closed 2008-02-07
Related to TYPO3 Core - Bug #18153: Docheaders: Module Web > Template : No docheader when no page has been chosen Closed 2008-02-07
Related to TYPO3 Core - Bug #18154: Docheaders: Module User Tools > User settings : No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18155: Docheaders: Module User Tools > Task center : No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18156: Docheaders: Module User Tools > Workspace: No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18157: Docheaders: Module Admin tools > User Admin: No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18158: Docheaders: Module Admin tools > Log: No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18159: Docheaders: Module Help > TypoScript Help: No docheader Closed 2008-02-07
Related to TYPO3 Core - Bug #18212: Docheaders: Wizard New Content Element (db_new_content_el.php): No docheader Closed 2008-02-14
Related to TYPO3 Core - Bug #18209: Docheaders: Wizard New Record/New page (db_new.php): No docheader Closed 2008-02-14
Related to TYPO3 Core - Bug #18196: Docheaders: Module Admin tools > Ext Manager: No docheader Closed 2008-02-12
Related to TYPO3 Core - Bug #18198: Docheaders: Module Admin tools > Configuration No docheader Closed 2008-02-12
Related to TYPO3 Core - Bug #18199: JS Errors with IE6 and new backend Closed 2008-02-13
Related to TYPO3 Core - Bug #18197: Docheaders: Module Admin tools > DB check: No docheader Closed 2008-02-12
Related to TYPO3 Core - Bug #18214: Docheaders: Wizard Table: No docheader Closed 2008-02-14
Related to TYPO3 Core - Bug #18215: Docheaders: Wizard Forms: No docheader Closed 2008-02-14
Related to TYPO3 Core - Bug #18216: Docheaders: Wizard RTE: No docheader Closed 2008-02-14
Related to TYPO3 Core - Bug #18217: Docheaders: Wizard tsconfig: No docheader Closed 2008-02-15
Related to TYPO3 Core - Bug #18218: Docheaders: Wizard Move Element (move_el.php): No docheader Closed 2008-02-15
Related to TYPO3 Core - Bug #18227: Docheaders: Module Import Export: No docheader Closed 2008-02-16
Related to TYPO3 Core - Bug #18232: Docheaders: Module History: No docheader Closed 2008-02-17
Related to TYPO3 Core - Bug #18256: Docheaders: Module Admin tools > Indexing: No docheader Closed 2008-02-20

History

#1 Updated by Benni Mack almost 12 years ago

This first patch does the following:
- Made the docheader in alt_doc.php HTML-template based.
- Added a function to retrieve a HTML template from template.php that can be overriden by a skin.
- Rearranged the buttons in the top bar.

#2 Updated by Patrick Broens almost 12 years ago

Next patch also covers the db_list
The db listing also has HTML template based docheader
Uses the same functionality as Benjamins.

#3 Updated by Ingo Renner almost 12 years ago

very good work guys! anyways there's room for improvement =)... see attached screens

#4 Updated by Patrick Broens almost 12 years ago

I'm still working on the docheader for page and template module. Hope I can get it in before feature freeze. Currently working on the page module docheader. Think it has more priority than template module.

Thanks for the improvements

#5 Updated by Ingo Renner almost 12 years ago

thanks for letting me know Patrick. I'd allow the docheader to go into SVN even after beta1... just to let you know. Nevertheless it would be very welcome to have it with beta1.

#6 Updated by Patrick Broens almost 12 years ago

Thanks Ingo. Page module is half way, so I expect everything to be ready before feature freeze

#7 Updated by Patrick Broens almost 12 years ago

New patch has been added.

This one covers the following modules:
  • Page
  • List
  • Template

There are some styling issues in IE which have to be solved. Icons are not at the right spot. Maybe Jens can have a look at the position of the icons.

I'll continue with the modules:
  • Info
  • Access
  • Functions
  • Versioning

What should I do? Commit this first to trunk and add the missing module docheaders later, or shall we do it at once?

#8 Updated by Ingo Renner almost 12 years ago

adding the missing ones later is ok with me

#9 Updated by Ingo Renner almost 12 years ago

Hi Patrick, here're some more notes on the latest patch... good job!

#10 Updated by Patrick Broens almost 12 years ago

Jeff Segars came with the request to put the 'Update' button in the docheader. This means the 'Cancel' button also has to go in there. I think the best solution is to use the appropriate icons for this.

Constant editor:
'savedok' icon instead of 'Update' button.
Now that I look at it the 'clear all cache' link can be deleted because this is already available in the top toolbar.

Info/Modify:
'savedok' icon instead of 'Update' button
'closedok' icon instead of 'Cancel' button
Same for 'clear all cache', should be deleted

Typoscript Object Browser:
Delete 'clear all cache'

Template analyzer:
No special remarks

#11 Updated by Ingo Renner almost 12 years ago

Hi Patrick, here're some more (minor) suggestions

#12 Updated by Patrick Broens almost 12 years ago

The icon after the text 'Viewing content of' is not redundant! The clickmenu of the page is connected to this icon. I don't think it is wise to remove the icon.

#13 Updated by Ingo Renner almost 12 years ago

ok, didn't notice

(now what to do with this creepy icon?)

#14 Updated by Helmut Hummel almost 12 years ago

What's the current status on this? Any up to date patches available?

#15 Updated by Patrick Broens almost 12 years ago

Last weekend I've rewritten some parts to make it more generic for each module. Currently I'm rewriting all core modules in 'Web' to use the docheader.

#16 Updated by Patrick Broens almost 12 years ago

Hi,

This is a new patch.

The 'Web' modules 'Page', 'List', 'Info' and 'Access' and 'Template' now have the docheader.

Benni did HTML templating only for the docheader. Now the whole output for the modules has a template. The main output of the modules is put in the marker ###CONTENT###. I've done this for future purposes of the HTML templating of the BE modules.

The next few days I'm going to implement the docheaders for the modules 'Functions' and 'Versioning'.

After that I will implement functionality so every function module, added by an extension, can add their own buttons or other stuff to the docheader.

The HTML templates have to move to the modules own dedicated directories.

Ingo asked me to send this patch to core list, although this is not finished yet.

Patrick

#17 Updated by Stefano Cecere almost 12 years ago

i', sorry i couldn not patch my core with this diff..
i usually get it done simply with (when in trunk/ )
patch -p2 < ./20080204_rfc7262.diff
or
patch -p1 < ./20080204_rfc7262.diff

what the correct syntax with this diff? thanks

#18 Updated by Patrick Broens almost 12 years ago

You are stripping of path levels. Simply use -p0

#19 Updated by Stefano Cecere almost 12 years ago

thanks patrick

i just made some checks and it seems very good!! (FF2 and Safari 3)

the only broken thing is the "back" button very far down, when i select a "new record" from the page module

#20 Updated by Stefano Cecere almost 12 years ago

thanks patrick

i just made some checks and it seems very good!! (FF2 and Safari 3)

the only broken thing is the "back" button very far down, when i select a "new record" from the page module

#21 Updated by Patrick Broens almost 12 years ago

I know there are some issues with IE6. Whenever the page is too long, the scrollbar is not at the right spot in some modules. This is a CSS issue which I'm going to resolve.

#22 Updated by Patrick Broens almost 12 years ago

Uploaded the changes for the docheader, splitted in to several patches.

20080205_rfc7262_base.diff: Base patch for template.php and stylesheet.css. Use this patch before applying any of the other patches.

20080205_rfc7262_page.diff: Web > Page module
20080205_rfc7262_list.diff: Web > List module
20080205_rfc7262_info.diff: Web > Info module
20080205_rfc7262_perm.diff: Web > Access module
20080205_rfc7262_func.diff: Web > Functions module
20080205_rfc7262_versioning.diff: Web > Versioning module
20080205_rfc7262_template.diff: Web > Template module

Docheader is tested in FF2, IE6, Opera9 and Safari3 on Windows

There are currently some open minor things which can be added after beta:
  • Extra row has to be added to the docheader
  • Version selector to extra row
  • Searchbox (in list module) to extra row
  • Record selector in Web > Page > Quickedit needs width (Adapts to the longest name which breaks the docheader)
  • Save & Abort buttons Access > User overview to docheader as icons
  • Refresh button Versioning to docheader as icon
  • Searchbox (Template > TS Object browser) to extra row
  • Styling of csh bubbles in docheader
  • Extension module functions need to be able to add their own buttons and buttongroups to the docheader
  • Move the html templates to the proper module locations
  • Make these modules completely templatable
  • Make html templates configurable for skin extensions

#23 Updated by Patrick Broens almost 12 years ago

Stefano,

I can't reproduce this broken back button you are talking about. I've never touched this part of the page module, so it still works like it did before. In my installation it does exactly what it's supposed to do.

Patrick

#24 Updated by Stefano Cecere almost 12 years ago

Hi patrink.. it's not really "broken".. i see just a 400px empty vertical space between the records list and the button..

anyway later i try with your new patches!

thanks
s

#25 Updated by Christoph Koehler almost 12 years ago

I'd like to add the File -> Filelist to that list. Working on the patch today.

#26 Updated by Patrick Broens almost 12 years ago

Hi Christoph,

Yeah, the plan is to add the docheader to other modules as well. But the first step has been made :-)

#27 Updated by Christoph Koehler almost 12 years ago

I am just saying I will work on the file list part :) It can be for beta2 if you want to push out beta1 fast, just saying I will work on that today.

#28 Updated by Patrick Broens almost 12 years ago

Docheader has been committed to trunk for the latest patches.

@Christoph: Could you please make another RFC in the bugtracker for the file module? Otherwise this RFC is getting too big and covers too much. Add only RFC for the list module, please

Thanks

#29 Updated by Patrick Broens almost 12 years ago

Committed to trunk

Also available in: Atom PDF