Feature #18505

Hide buttons in Listview

Added by Georg Ringer about 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-03-27
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

Currently it is not possible to hide specific icons of the list view (with Extended view enabled). It is a all or nothing.

With the attached patch it is possible to
- hide specific icons for all tables
- hide specific icons for specific tables.

Syntax is the following one in Page TsConfig
mod.web_list.hideIcon.pages = view,info
mod.web_list.hideIcon = edit

the following icons are hideable:
view, edit, move, info, history, versioning, permission, newafter, sort, hide, delete, movelevel

(issue imported from #M7948)


Files

patch-tsconfigbuttons.patch (9.06 KB) patch-tsconfigbuttons.patch Administrator Admin, 2008-03-27 20:56
#1

Updated by Markus Bucher about 12 years ago

Confirmed the patch, still working in 4.2.5.

But: having spaces after the commata in Ts doesn't work.

Working:
mod.web_list.hideIcon.tt_content = delete,newafter,history,versioning,move,info,sort

Not working:
mod.web_list.hideIcon.tt_content = delete, newafter, history, versioning, move, info, sort

Here only "delete" is evaluated

#2

Updated by Markus Bucher about 12 years ago

Is it possible to deny access to cut/copy/paste as well?

#3

Updated by Bernhard Kraft about 12 years ago

There is an extension from me, which utilizes a hook, to allow exactly this feature.
Not everything must be packed into the core:

http://typo3.org/extensions/repository/view/kb_modlist_actions/current/

It comes with even more featuers (Showing buttons depending on BE user/group) and full documentation. Have phun. If this fits your needs, feel free to change this bug to resolved.

#4

Updated by Mathias Schreiber over 6 years ago

  • Description updated (diff)
  • Status changed from New to Closed
  • Target version deleted (0)

dupe

Also available in: Atom PDF