Bug #18640

EM considers 0.8.0 to be have a higher number than 1.0.0

Added by Oliver Klee about 13 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2008-04-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This bug concerns the sorting of version numbers and the update function.

A) Sorting of version numbers:

1. In the EM, select "Import".
2. Enter ameos_formidable.
3. In the search result, click on the extension title.
4. Next to "Load details", open the drop-down list with the version numbers.

Expected result:
...
0.7.0
0.8.0
1.0.0

Actual result:
0.7.0
1.0.0
0.8.0

B) the update mechanism

1. Install ameos_formidable 0.7.0.
2. In the EM, select "Check for extension updated".

Expected result:
The updater offers to update ameos_formidable to the latest version 1.0.0.

Actual result:
The updater offers to update ameos_formidable to the no-latest version 0.8.0.

When ameos_formidable 0.8.0 is installed, the updater show ameos to be up-to-date.

Interestingly, when you use import_extensions with 0.8.0 installed, the result list will show you the green "update" icon, allowing you to upgrade from 0.8.0 to 1.0.0.
(issue imported from #M8158)


Files

8158.diff (998 Bytes) 8158.diff Administrator Admin, 2008-04-19 15:39

Related issues

Related to TYPO3 Core - Bug #22378: "Check for extension updates" does not always find latest versionClosedJeff Segars2010-04-05

Actions
Related to TYPO3 Core - Bug #22441: importExtInfo() does not sort versions correctlyClosedFrancois Suter2010-04-13

Actions
#1

Updated by Rob Vonk about 13 years ago

Reproducable.

Fix is to change line 101 from typo3/mod/tools/em/class.em_xmlhandler.php from

$order = $forder.', title';

to

$order = $forder.', title,version';

The updates list is also correct now.

#2

Updated by Oliver Klee about 13 years ago

Rob, this helps with the ameos_formidable case, but doesn't work for two-digit numbers. In this case, the "seminars" extension will have the following order:

0.4.0
0.4.1
0.4.11
0.4.12
0.4.2
0.4.3
...

#3

Updated by Marcus Krause over 12 years ago

Is there nobody interested in providing a Core patch?

#4

Updated by Chris topher about 11 years ago

Resolved as duplicate of #22378 and #22378.

#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF