Bug #18696

Drag and Drop problems with flexform sections

Added by Jan over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-04-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have a list of item in a section, you can't move width the drag and drop each item.
You can go down but with difficulties and can't go up.
It's worse when you have a long list

(issue imported from #M8244)


Files

example.mov (703 KB) example.mov Administrator Admin, 2008-05-13 16:19

Related issues

Is duplicate of TYPO3 Core - Bug #19049: drag & drop of section elements and IRRE records does not work if frame has to be scrolledClosedOliver Hader2008-07-02

Actions
#1

Updated by Mathias Bolt Lesniak over 12 years ago

I'm experiencing the same problem in templavoila. I can drag an item, but can't drop it anywhere. I attached a movie showing my problems.

#2

Updated by Oliver Berg over 12 years ago

I can confirm this, too.

And since there seems to be no other way in TYPO3 4.2 to reorder sections (like the up/down buttons in previous versions) this feature is pretty much unusable at the moment.

If I remember right this more or less worked in one of the betas (jerky, but it worked) but I can't remember in which one.

EDIT:
I forgot to say, I checked with every browser available to me (FF, IE 6+7, Safari, Opera, Camino) on Windows and OS X.

#3

Updated by jochen kast over 12 years ago

i have the same problem. by testing different combinations i find out that this problem will occur by mixing sections with other elements.
expl:
CO, EL, EL, SC,CO,EL,EL,CO,EL
drag and drop donĀ“t work
spliting this fce in two different fce's it will work:
1.block:
CO, EL, EL
2.block:
CO,SC,CO,EL,EL,CO,EL
example don't work when using RTE in one element

may this will be helpful for others

#4

Updated by Dmitry Dulepov over 12 years ago

Mathias Bolt Lesniak, TemplaVoila does not move sections or create forms. TYPO3 does!

#6

Updated by Sebastian Fuchs almost 12 years ago

could you test the patch under http://bugs.typo3.org/view.php?id=8882 if it solves this problem? its a prototype/sortable issue that appears only when the page has been scrolled (and the offset gets calculated wrong).

#7

Updated by Oliver Hader over 11 years ago

This issue was solved in #19049.

There is a sponsorship of 100,00 Euro by Mathias Bolt Lesniak. Affected parties in creating a patch were Sebastian Fuchs and Helmut Hummel. Please get in contact with me directly (oliver @ typo3 . org) if you have problems concerning the sponsorship...

Also available in: Atom PDF