Bug #19049

drag & drop of section elements and IRRE records does not work if frame has to be scrolled

Added by Christian Clemens over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-07-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After upgrading to 1.3.6 and Typo3 4.2.1 we are no longer able to change the order (position) of section-elements in a tv-object: there is a section in a tv-object for collecting links. In previous versions of templavoila it was possible to change the position of these links with arrow-buttons. In 1.3.6. this should be done with drag & drop. I can drag a section-element, but I'm not able to drop it at another position (see screenshot). Am I too silly or is it a bug? ;-)

Tested in FF2 and IE7.

(issue imported from #M8882)


Files

screenshot_drag_and_drop.gif (96.3 KB) screenshot_drag_and_drop.gif Administrator Admin, 2008-07-02 13:31
screenshot_sensitive_area_drag_n_drop_firefox_2_0_0_16.gif (85.7 KB) screenshot_sensitive_area_drag_n_drop_firefox_2_0_0_16.gif Administrator Admin, 2008-08-15 10:20
T3X_test_flexform_sections-0_0_0-z-200810271429.t3x (6.91 KB) T3X_test_flexform_sections-0_0_0-z-200810271429.t3x Administrator Admin, 2008-10-27 14:33
8882_v1.patch (493 Bytes) 8882_v1.patch Administrator Admin, 2009-01-08 17:51

Related issues

Related to TYPO3 Core - Bug #19496: Flexform sections are not working anymore since script.aculo.us is not loadedClosedOliver Hader2008-10-22

Actions
Has duplicate TYPO3 Core - Bug #18696: Drag and Drop problems with flexform sectionsClosedOliver Hader2008-04-24

Actions
#1

Updated by Lee Perry over 12 years ago

same problem for me - but I realized that the other items are moving when I move the dragged item beneath, much of beneath the section list, but sometimes the place on the page is not enough to get every position ;)

#2

Updated by Christian Clemens over 12 years ago

Tried to move an element much of beneath the section list - but your workaround doesn't work for me. What browser do you use? Can you probably make a screenshot for me (to see "how much beneath" ;-)?

#3

Updated by Lee Perry over 12 years ago

I think this shouldn't be a workaround - it's more a hint to solve the problem, but okay you can use it sometimes as a workaround :)
This "works" for me in Firefox 2.0.0.16 (and some versions below) and also in IE7 and IE6 (but in IE6 the sensitive area is more beneath than in FF2 or IE7).
It will "works" in Firefox 3, too - but the sensitive area seems to be so much beneath, that it's often at the end of page and so it's not useably.

See the screenshot (Firefox 2.0.0.16).

#4

Updated by Christian Clemens over 12 years ago

Thank you lee! Unfortunately we cannot reconstruct this effect in our installation... :-(

#5

Updated by Xavier Perseguers over 12 years ago

I can confirm too that it is much more difficult to move something with the drag and drop feature and it should be either fixed soon or go back to the old-fashioned but working arrows.

#6

Updated by Lee Perry over 12 years ago

I hope this will not go back to the old-fashioned arrows, because there are problems as well!
With the old fashioned arrows I've got sometimes empty section-nodes in the corresponding XML - delete one section inside the list and than change the order by this deleted position - but be careful, because after the error occurs you cannot edit the FCE, you have to delete the empty section-node in the corresponding XML in the database.
And the old fashioned arrows are not very user-friendly, when you have a very long list and you have to change the whole order - it takes hours with the step-by-step-arrows and you have to hope, that the XML-structure will stay clean.

So please find a way to solve the problem with drag and drop.

#7

Updated by Lee Perry about 12 years ago

Anybody knows what is going on to solve this bug?
I think it's an important problem! - But nobody is assigned to this bug :(

#8

Updated by Christian Clemens about 12 years ago

In TYPO3 4.2.2 the problem still exists. But: I can't not even drag any elements - when I move mouse arrow above the icon "drag & drop", the arrow doesn't change appearance. When I move arrow above the icon "delete", appearance changes correctly.

#9

Updated by Philipp Heine about 12 years ago

I can confirm that this problem still exits in TYPO3 4.2.2 an TemplaVoila 3.1.6 and 3.1.7.
It's not a browser problem (no function on the drag&drop icon nor the headline) in Firefox 3, Firefox 2 and IE6.

And YES: For me it is an important problem, too!

#10

Updated by Florian Seirer about 12 years ago

+1 for importance. It makes section containers almost unusable and on one of our websites relies heavily on this feature.

I do get a JS error in IE7 ("'Sortable' is undefined"), if that helps.

#11

Updated by Oliver Hader about 12 years ago

Is this issue related to TemplaVoila only or can it be reproduced in "regular" TYPO3 environments as well? Can anybody please attach a FlexForm snippet that uses sections and produces this behaviour?

#12

Updated by Florian Seirer about 12 years ago

There you go:


<T3DataStructure>
<meta type="array">
<langDisable>1</langDisable>
</meta>
<ROOT type="array">
<tx_templavoila type="array">
<title>ROOT</title>
<description>Select the HTML element on the page which you want to be the overall container element for the template.</description>
</tx_templavoila>
<type>array</type>
<el type="array">
<field_mitarbeiter_zustaendigkeiten_container type="array">
<type>array</type>
<section>1</section>
<tx_templavoila type="array">
<title>Zustaendigkeiten Container</title>
<eType>input</eType>
</tx_templavoila>
<el type="array">
<field_mitarbeiter_zustaendigkeiten type="array">
<type>array</type>
<tx_templavoila type="array">
<title>Zustaendigkeiten</title>
<eType>input</eType>
</tx_templavoila>
<el type="array">
<field_mitarbeiter_zustaendigkeit type="array">
<tx_templavoila type="array">
<title>Zustaendigkeit</title>
<sample_data type="array">
<numIndex index="0">Zustaendigkeit 1</numIndex>
</sample_data>
<eType>input</eType>
<TypoScript>
10 = TEXT
10.current = 1
10.typolink.parameter.field = field_mitarbeiter_zustaendigkeit_url
</TypoScript>
<proc type="array">
<HSC type="integer">1</HSC>
</proc>
</tx_templavoila>
<TCEforms type="array">
<config type="array">
<type>input</type>
<size>48</size>
<eval>trim</eval>
</config>
<label>Zustaendigkeit</label>
</TCEforms>
</field_mitarbeiter_zustaendigkeit>
<field_mitarbeiter_zustaendigkeit_url type="array">
<type>attr</type>
<tx_templavoila type="array">
<title>URL</title>
<sample_data type="array">
<numIndex index="0">www.dvt.at&lt;/numIndex>
</sample_data>
<eType>link</eType>
<TypoScript>
10 = TEXT
10.typolink.parameter.current = 1
10.typolink.returnLast = url
</TypoScript>
<proc type="array">
<HSC type="integer">1</HSC>
</proc>
</tx_templavoila>
<TCEforms type="array">
<config type="array">
<type>input</type>
<size>15</size>
<max>256</max>
<checkbox></checkbox>
<eval>trim</eval>
<wizards type="array">
<_PADDING type="integer">2</_PADDING>
<link type="array">
<type>popup</type>
<title>Link</title>
<icon>link_popup.gif</icon>
<script>browse_links.php?mode=wizard</script>
<JSopenParams>height=300,width=500,status=0,menubar=0,scrollbars=1</JSopenParams>
</link>
</wizards>
</config>
<label>URL</label>
</TCEforms>
</field_mitarbeiter_zustaendigkeit_url>
</el>
</field_mitarbeiter_zustaendigkeiten>
</el>
</field_mitarbeiter_zustaendigkeiten_container>
</el>
</ROOT>
</T3DataStructure>

#13

Updated by Florian Seirer about 12 years ago

This looks like a duplicate of http://bugs.typo3.org/view.php?id=8244 ...

#14

Updated by Steffen Kamper about 12 years ago

I can confirm a problem there.
I attached a demo extension with flexform section in plugin configuration.

I'm not able to drag anymore, error given is:
Sortable is not defined
http://localhost/t3/home/typo3/alt_doc.php?returnUrl=%2Ft3%2Fhome%2Ftypo3%2Fsysext%2Fcms%2Flayout%2Fdb_layout.php%3Fid%3D26&edit[tt_content][78,]=edit
Line 687

#15

Updated by Oliver Hader about 12 years ago

Hm, thanks for the information you gave - but we have to distinguish:
1) This issue seems to be about wrong handling in TemplaVoila since dragging is possible and no JavaScript error on "Sortable" occurs
2) The different issue was introduced in TYPO3 4.2.2 and didn't load script.aculo.us at all and this the JavaScript error gets shown - see issue #19496 for a patch

#16

Updated by Florian Seirer about 12 years ago

After applying the patch from http://bugs.typo3.org/view.php?id=9623 I get the following error:

PHP Fatal error: Call to undefined method t3lib_TCEforms::loadJavascriptLib() in /var/www/html/typo3/t3lib/class.t3lib_tceforms.php

Did I miss something or does this patch apply to the SVN version only? I use the official version 4.2.2...

#17

Updated by Oliver Hader about 12 years ago

Florian, there were some other patches and fixed involved in this issue. So, the best thing would be to check out the TYPO3_4-2 branch from SVN (that's the version that will be released as TYPO3 4.2.3 soon).

#18

Updated by Lee Perry about 12 years ago

Friday, the 7th november I have installed the TYPO3 4.2.3dev from SVN - in this version I've got no Javascript-Error by clicking on the drag'n'drop-icon BUT I have still the same problem to find the sensitive area, where the other items will move to reorder the items. It seems, that these areas are still much beneath the section list.

So, I hope the whole (!) problem will be fixed in the final version of TYPO3 4.2.3.

#19

Updated by Oliver Hader about 12 years ago

Lee,
what browser are you using? Do you have TemplaVoila installed? Thanks for the additional information!
Best regards, Oliver "John Doe" Hader

#20

Updated by Christian Clemens about 12 years ago

In TYPO3 4.2.3 the problem still exists. Now I can drag items again - but I can't still drop them. Tested in FF3 and IE7. Using TemplaVoila 1.3.7. This is the XML of my TV-object:


<T3DataStructure>
<meta type="array">
<langDisable>1</langDisable>
</meta>
<ROOT type="array">
<tx_templavoila type="array">
<title>ROOT</title>
<description>Select the HTML element on the page which you want to be the overall container element for the template.</description>
</tx_templavoila>
<type>array</type>
<el type="array">
<field_title type="array">
<tx_templavoila type="array">
<title>Title</title>
<description><![CDATA[<h1 class="titel">...</h1>]]></description>
<sample_data type="array">
<numIndex index="0">Ich bin eine Titel</numIndex>
</sample_data>
<eType>input</eType>
<proc type="array">
<HSC type="integer">1</HSC>
</proc>
</tx_templavoila>
<TCEforms type="array">
<config type="array">
<type>input</type>
<size>48</size>
<eval>trim</eval>
</config>
<label>Title</label>
</TCEforms>
</field_title>

<field_subtitle type="array">
<tx_templavoila type="array">
<title>Subtitle</title>
<description><![CDATA[<h2 class="subtitle">...</h2> - wobei dieser Wrap per TS gesetzt wird]]></description>
<sample_data type="array">
<numIndex index="0">Ich bin ein Subtitle</numIndex>
</sample_data>
<eType>input</eType>
<TypoScript><![CDATA[
10 = TEXT
10.current = 1
10.required=1
10.wrap=<h2 class="subtitle">|</h2>
  1. Folgende Zeilen einkommentieren zum Debuggen
  2. 20 = TEXT
  3. 20.field = field_image_border
  4. 20.required=1
  5. 20.wrap=<h2>|</h2>
    ]]></TypoScript>
    <proc type="array">
    <HSC type="integer">0</HSC>
    </proc>
    </tx_templavoila>
    <TCEforms type="array">
    <config type="array">
    <type>input</type>
    <size>48</size>
    <eval>trim</eval>
    </config>
    <label>Subtitle</label>
    </TCEforms>
    </field_subtitle>
&lt;field_image type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Bild&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;p class="image"&gt;&lt;img .../&gt;&lt;/p&gt; - wobei dieser Wrap per TS gesetzt wird]]>&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;![CDATA[&lt;img src=&quot;test.gif&quot; /&gt;]]&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;image&lt;/eType&gt;
&lt;TypoScript&gt;&lt;![CDATA[
10 = COA
10.3 = TEXT
10.3 {
value=0
if.isTrue.field = field_image
}
10.3.value=&lt;div class="image"&gt;
10.5 = TEXT
10.5 {
value = 0
if.isTrue.field = field_image_border
}
10.5.value=&lt;div class="csc-image-border"&gt;
10.6 = TEXT
10.6 {
value = 1
if.isTrue.field = field_image_nofloat
}
10.6.value=&lt;p class="nofloat"&gt;
10.10=IMAGE
10 {
10.altText.field = field_image_alttext
10.titleText.field = field_image_titletext
10.file.import = uploads/tx_templavoila/
10.file.import.current = 1
10.file.import.listNum = 0
10.file.width.field = field_image_width
10.file.height.field = field_image_height
10.file.maxW = 400
10.stdWrap.typolink.parameter.field = field_image_link # Alle externen Links werden automatisch in einem neuen Fenster geöffnet:
10.stdWrap.typolink.extTarget = _blank
#14101.stdWrap.required=1
#14101.stdWrap.typolink.wrap=&lt;p class="image"&gt;|&lt;/p&gt;
}
10.14 = TEXT
10.14 {
value = 1
if.isTrue.field = field_image_nofloat
}
10.14.value=&lt;/p&gt;
10.15 = TEXT
10.15 {
value = 0
if.isTrue.field = field_image_border
}
10.15.value=&lt;/div&gt;
10.20 = TEXT
10.20 {
value=0
if.isTrue.field = field_image
}
10.20.value=&lt;/div&gt;
]]>
&lt;/TypoScript&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;group&lt;/type&gt;
&lt;internal_type&gt;file&lt;/internal_type&gt;
&lt;allowed&gt;gif,png,jpg,jpeg&lt;/allowed&gt;
&lt;max_size&gt;1000&lt;/max_size&gt;
&lt;uploadfolder&gt;uploads/tx_templavoila&lt;/uploadfolder&gt;
&lt;show_thumbs&gt;1&lt;/show_thumbs&gt;
&lt;size&gt;1&lt;/size&gt;
&lt;maxitems&gt;1&lt;/maxitems&gt;
&lt;minitems&gt;0&lt;/minitems&gt;
&lt;/config&gt;
&lt;label&gt;Bild&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image&gt;
&lt;field_image_alttext type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Image Alt-Text&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;40&lt;/size&gt;
&lt;default&gt;&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Bild - Alt-Text&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_alttext&gt;
&lt;field_image_titletext type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Image Title-Text&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;40&lt;/size&gt;
&lt;default&gt;&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Bild - Titel-Text&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_titletext&gt;
&lt;field_image_link type="array"&gt;
&lt;type&gt;attr&lt;/type&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Image-Link&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;link&lt;/eType&gt;
&lt;TypoScript&gt;&lt;![CDATA[
10 = TEXT
10.typolink.typolink.parameter.field = field_link]]>
&lt;/TypoScript&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;15&lt;/size&gt;
&lt;max&gt;256&lt;/max&gt;
&lt;checkbox&gt;&lt;/checkbox&gt;
&lt;eval&gt;trim&lt;/eval&gt;
&lt;wizards type="array"&gt;
&lt;_PADDING type="integer"&gt;2&lt;/_PADDING&gt;
&lt;link type="array"&gt;
&lt;type&gt;popup&lt;/type&gt;
&lt;title&gt;Link&lt;/title&gt;
&lt;icon&gt;link_popup.gif&lt;/icon&gt;
&lt;script&gt;browse_links.php?mode=wizard&lt;/script&gt;
&lt;JSopenParams&gt;height=300,width=500,status=0,menubar=0,scrollbars=1&lt;/JSopenParams&gt;
&lt;/link&gt;
&lt;/wizards&gt;
&lt;/config&gt;
&lt;label&gt;Bild - Link&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_link&gt;
&lt;field_image_height type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;height&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;4&lt;/size&gt;
&lt;eval&gt;int&lt;/eval&gt;
&lt;checkbox&gt;0&lt;/checkbox&gt;
&lt;range type="array"&gt;
&lt;upper&gt;400&lt;/upper&gt;
&lt;lower&gt;0&lt;/lower&gt;
&lt;/range&gt;
&lt;default&gt;0&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Bildhoehe&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_height&gt;
&lt;field_image_width type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;width&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;4&lt;/size&gt;
&lt;eval&gt;int&lt;/eval&gt;
&lt;checkbox&gt;0&lt;/checkbox&gt;
&lt;range type="array"&gt;
&lt;upper&gt;300&lt;/upper&gt;
&lt;lower&gt;0&lt;/lower&gt;
&lt;/range&gt;
&lt;default&gt;0&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Bildbreite&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_width&gt;
&lt;field_image_border type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;border&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;select&lt;/eType&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;select&lt;/type&gt;
&lt;items type="array"&gt;
&lt;numIndex index="0" type="array"&gt;
&lt;numIndex index="0"&gt;Nein&lt;/numIndex&gt;
&lt;numIndex index="1"&gt;0&lt;/numIndex&gt;
&lt;/numIndex&gt;
&lt;numIndex index="1" type="array"&gt;
&lt;numIndex index="0"&gt;Ja&lt;/numIndex&gt;
&lt;numIndex index="1"&gt;1&lt;/numIndex&gt;
&lt;/numIndex&gt;
&lt;/items&gt;
&lt;default&gt;0&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Rahmen um Bild?&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_border&gt;
&lt;field_image_nofloat type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;nofloat&lt;/title&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;select&lt;/eType&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;select&lt;/type&gt;
&lt;items type="array"&gt;
&lt;numIndex index="0" type="array"&gt;
&lt;numIndex index="0"&gt;Ja&lt;/numIndex&gt;
&lt;numIndex index="1"&gt;0&lt;/numIndex&gt;
&lt;/numIndex&gt;
&lt;numIndex index="1" type="array"&gt;
&lt;numIndex index="0"&gt;Nein&lt;/numIndex&gt;
&lt;numIndex index="1"&gt;1&lt;/numIndex&gt;
&lt;/numIndex&gt;
&lt;/items&gt;
&lt;default&gt;0&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Text um Bild fliessen lassen?&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_image_nofloat&gt;
&lt;field_text type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Text&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;p&gt;...&lt;/p&gt;]]>&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;Ich bin ein Text&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;rte&lt;/eType&gt;
&lt;TypoScript&gt;&lt;![CDATA[
10 = COA
10.5 = TEXT
10.5 {
value = 1
if.isTrue.field = field_image_nofloat
}
10.5.value=&lt;div class="nofloat"&gt;
10.10 = TEXT
10.10.current = 1
10.10.parseFunc = < lib.parseFunc_RTE
10.15 = TEXT
10.15 {
value = 1
if.isTrue.field = field_image_nofloat
}
10.15.value=&lt;/div&gt;
]]>&lt;/TypoScript&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;0&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;text&lt;/type&gt;
&lt;cols&gt;48&lt;/cols&gt;
&lt;rows&gt;5&lt;/rows&gt;
&lt;softref&gt;typolink_tag,images,email[subst],url&lt;/softref&gt;
&lt;/config&gt;
&lt;label&gt;Text&lt;/label&gt;
&lt;defaultExtras&gt;richtext:rte_transform[flag=rte_enabled|mode=ts_css]&lt;/defaultExtras&gt;
&lt;/TCEforms&gt;
&lt;/field_text&gt;
&lt;field_link_segment type="array"&gt;
&lt;type&gt;array&lt;/type&gt;
&lt;section&gt;1&lt;/section&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Container fuer alle Links&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;div class="links"&gt;...&lt;/div&gt;]]>&lt;/description&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;/tx_templavoila&gt;
&lt;el type="array"&gt;
&lt;field_link type="array"&gt;
&lt;type&gt;array&lt;/type&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Einzelner Link&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;div class="link"&gt;...&lt;/div&gt;]]>&lt;/description&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;/tx_templavoila&gt;
&lt;el type="array"&gt;
&lt;field_linktext type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Linktext&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;a&gt;...&lt;/a&gt;]]>&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;Weiter geht's&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;48&lt;/size&gt;
&lt;eval&gt;trim&lt;/eval&gt;
&lt;/config&gt;
&lt;label&gt;Linktext&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_linktext&gt;
&lt;field_linknote type="array"&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Linknote&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[&lt;span class="linknote"&gt;...&lt;/span&gt;]]>&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;Link-Notiz&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;TypoScript&gt;&lt;![CDATA[
10 = TEXT
10.current = 1
10.required=1
10.wrap = &nbsp;|
]]>&lt;/TypoScript&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;0&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;48&lt;/size&gt;
&lt;eval&gt;trim&lt;/eval&gt;
&lt;/config&gt;
&lt;label&gt;Text nach Link&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_linknote&gt;
&lt;field_linkto type="array"&gt;
&lt;type&gt;attr&lt;/type&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Linkziel&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[src="..."]]&gt;&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;test.htm&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;link&lt;/eType&gt;
&lt;TypoScript&gt;
10 = TEXT
10.typolink.parameter.current = 1
10.typolink.returnLast = url
&lt;/TypoScript&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;15&lt;/size&gt;
&lt;max&gt;256&lt;/max&gt;
&lt;checkbox&gt;&lt;/checkbox&gt;
&lt;eval&gt;trim&lt;/eval&gt;
&lt;wizards type="array"&gt;
&lt;_PADDING type="integer"&gt;2&lt;/_PADDING&gt;
&lt;link type="array"&gt;
&lt;type&gt;popup&lt;/type&gt;
&lt;title&gt;Link&lt;/title&gt;
&lt;icon&gt;link_popup.gif&lt;/icon&gt;
&lt;script&gt;browse_links.php?mode=wizard&lt;/script&gt;
&lt;JSopenParams&gt;height=300,width=500,status=0,menubar=0,scrollbars=1&lt;/JSopenParams&gt;
&lt;/link&gt;
&lt;/wizards&gt;
&lt;/config&gt;
&lt;label&gt;Linkziel&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_linkto&gt;
&lt;field_linktarget type="array"&gt;
&lt;type&gt;attr&lt;/type&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Linktarget&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[target="..."]]&gt;&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;_blank&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;48&lt;/size&gt;
&lt;eval&gt;trim, required&lt;/eval&gt;
&lt;default&gt;_top&lt;/default&gt;
&lt;/config&gt;
&lt;label&gt;Linktarget&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_linktarget&gt;
&lt;field_linktitle type="array"&gt;
&lt;type&gt;attr&lt;/type&gt;
&lt;tx_templavoila type="array"&gt;
&lt;title&gt;Link-Title&lt;/title&gt;
&lt;description&gt;&lt;![CDATA[title="..."]]&gt;&lt;/description&gt;
&lt;sample_data type="array"&gt;
&lt;numIndex index="0"&gt;huhu&lt;/numIndex&gt;
&lt;/sample_data&gt;
&lt;eType&gt;input&lt;/eType&gt;
&lt;proc type="array"&gt;
&lt;HSC type="integer"&gt;1&lt;/HSC&gt;
&lt;/proc&gt;
&lt;/tx_templavoila&gt;
&lt;TCEforms type="array"&gt;
&lt;config type="array"&gt;
&lt;type&gt;input&lt;/type&gt;
&lt;size&gt;48&lt;/size&gt;
&lt;eval&gt;trim&lt;/eval&gt;
&lt;/config&gt;
&lt;label&gt;Link-Title&lt;/label&gt;
&lt;/TCEforms&gt;
&lt;/field_linktitle&gt;
&lt;/el&gt;
&lt;/field_link&gt;
&lt;/el&gt;
&lt;/field_link_segment&gt;
&lt;/el&gt;
&lt;/ROOT&gt;
&lt;/T3DataStructure&gt;
#21

Updated by Michael Voehringer about 12 years ago

I can reproduce this bug, with enabled RTE in typo3 4.2.3.
Please have look at Bug 8232 which fixed a bug in the trunk but not in the 4.2 branch. Also see Bug 9666.

#22

Updated by Christian Clemens about 12 years ago

Seems to have nothing to do with RTE - or what do you mean Michael?
I turned off RTE and problem still exists

#23

Updated by Lee Perry about 12 years ago

Hey Oliver,
Chrisitan reported the browser-version and I did it here at the beginning of the bugreport (note 0023911) and yes I have installed TemplaVoila. Where else can I use these sections? - IRRE, okay - hmmm does it work there? - No, same problem there: the sensitive area is also much beneath the section, but there are also the old fashioned up- and down-arrows for changing the order.

so I can find the problem by sections in TemplaVoila and in IRRE - so it seems to be a problem by the TYPO3 core handling of section reordering ...

#24

Updated by Florian Seirer about 12 years ago

I just accidentally found out that you can drag AND DROP the elements when you minimize them to their title bar.
Not perfect yet, because the "drop zone" is still quite a bit off, but at least it's usable now.

Also, this looks related to http://bugs.typo3.org/view.php?id=8244, which makes solving it worth 130€. ;-)

#25

Updated by Christian Clemens almost 12 years ago

I cannot find the mentioned "drop zone" (trying it in FF3). Don't know, why this "workaround" doesn't work in my installation...

#26

Updated by Gregor Nathanael Meyer almost 12 years ago

At our site (TYPO3 4.2.3), script.aculo.us is loaded and the dragging works quite well. Only the drop zones are completely mad, and most of the time out of the viewport. If I minimize the Sections, I can sometimes get the dropzone somewehere inside the viewport, but several hundered pixels off the correct position.

E.g. a textarea section above some other sections influences the position of their drop zones: When it is minimized, the dropzones have an offset of about 300px, when it is opened, the drop zones offsets increase by the height of the textarea.

Can anyone reproduce this behaviour?

#27

Updated by Florian Seirer almost 12 years ago

I can.
It seems like the drop zones are calculated wrong by adding height when it shouldn't.

This issue is literally dragging now. ;-)

#28

Updated by Lee Perry almost 12 years ago

Yes we can! :) ...as I wrote in every second of my notes on this bug report.

Chrisitan, you cannot find the dropzone?
Maybe try it by changing the FCE field order - put the section list first and than all other fields of the FCE - so you will get some more space beneath the list to find the dropzone. - It's no solution only a hint to reproduce our field report or maybe sometimes a workaround - no, it's not a workaround, it's a minimal way to use the drag and drop in some way ...

#29

Updated by Frederik Mathem almost 12 years ago

Funny thing

If i resize the page with firefox zoom option, the position of the dropzones are no more miscalculated. If i go back to 100% zoom it stays that way only for one drop.

#30

Updated by Christian Clemens almost 12 years ago

I tried Frederiks "workaround": if I zoom out in firefox3 several steps so that I couldn't really read the headlines any longer - than I discover dropzones. But in my firefox, they do not have the correct position - they are hundret of pixels below.

Update: if I zoom out 5 steps, than the dropzones have the correct position...

#31

Updated by Sebastian Fuchs almost 12 years ago

Hi,
I think I had the same issue in an extension were we us flexforms to sort elements. the problem only occured if you had a long list and you had to scroll to position the element.
so like somebody else pointed out, if you scroll a little the offset will be small, if you scroll a lot the offset will be bigger.
I think this problem is related to these prototype/scriptacoulse issues:
http://dev.rubyonrails.org/ticket/3860
http://dev.rubyonrails.org/ticket/11255

But for me the 8882_v1.patch works (its a trial&error patch). It is only tested on FF2 against my own extensions (i dont have TV enabled).

#32

Updated by Lee Perry almost 12 years ago

Hi Sebastian,

it looks great (and easy ;) ...

Your patch works for me in FF2, FF3, IE6, IE7 and Safari with TemplaVoila!
It doesn't works for me in IRRE - but maybe it's another IRRE-setting problem ...

So long, GREAT WORK!

#33

Updated by Sebastian Fuchs almost 12 years ago

Hi Lee,

good to here that it works for you.

As far as i remeber (some webcast from kasper) IRRE and these flexform sections are two totally different concepts (which both work with scriptacoulse drag'n'drop).
To fix this for IRRE too you have to edit t3lib/jsfunc.inline.js.
Insert
Position.includeScrollOffsets = true;
on line 473.

Sorry that i cant provide a patch this time.

#34

Updated by Lee Perry almost 12 years ago

Hey Sebastian,

thanx again!
I've patched the t3lib/jsfunc.inline.js manually and it works also fine now.

So please contact the TYPO3 core team to insert your patches for the next release.

greetings,
Lee

#35

Updated by Helmut Hummel almost 12 years ago

Thanks, Sebastian for finding a solution for this problem! I submitted the patch (icluding the IRRE fix) to the core list.

#36

Updated by Tobias Liebig almost 12 years ago

i tried the patch but it didn't solved the issue for me.

When i try to Drag an dDrop a section the Browser thorws a javascript error "Sortable is not undefined" (like Steffen Kamper and Florian Seirer reported).
For it works well when i include Scriptaculous in alt_doc.php

Line 458
+ $this->doc->loadJavascriptLib('contrib/scriptaculous/scriptaculous.js?load=effects,dragdrop');

#37

Updated by Lee Perry almost 12 years ago

hey tobias,

maybe you were working with TYPO3 4.2.2?

I guess, there was a bug (http://bugs.typo3.org/view.php?id=9623 ) by loading or no more loading of script.aculo.us.
there is a patch and it was solved in TYPO3 4.2.3 ...

greetings,
lee

#38

Updated by Tobias Liebig almost 12 years ago

You're right! I stumpled over this in a customers project which still runs on 4.2.2.
The issue concering the missing scriptaculous.js is solved with #19496 and its solved in 4.2.3.

#39

Updated by Lee Perry almost 12 years ago

Is this patch included in the release 4.2.4 now?

#40

Updated by Laurent Cherpit almost 12 years ago

it does not seem so.

tx for the patch!

#41

Updated by Alban Cousinie over 11 years ago

The issue is still present in Typo3 4.2.6, and the patch attached to this issue does work (applied manually as line numbers may differ in Typo3 4.2.6).

#42

Updated by Stefan Froemken over 11 years ago

I have still the same problem in 4.2.6 and alpha 2. I searched for Position.includeScrollOffsets = true; in jsfunc.inline.js, but it isn't there?! When I don't scroll, than everything works fine, but with scrolling the offset get's bigger.

#43

Updated by Stefan Froemken over 11 years ago

TYPO3 Alpha 2:
I've looked into the Patch, searched for "function flexFormSortable" and saw, that I have to ADD not to EDIT a line.

After adding the new line in function drag and drop works perfectly.

THX

#44

Updated by Oliver Hader over 11 years ago

Committed to SVN:
  • TYPO3_4-2 (rev. 5302)
  • Trunk (rev. 5303)

There is a sponsorship of 30,00 Euro by Christian Clemens. Affected parties in creating a patch were Sebastian Fuchs and Helmut Hummel.
Please get in contact with me directly (oliver @ typo3 . org) if you have problems concerning the sponsorship...

Also available in: Atom PDF