Feature #19419

Content in generated page or editing is messed up

Added by Pierrick Caillon over 12 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-10-06
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

Even if the content is correct in the database, when the page is generated or the content edited in the backend, its rte text is messed up. An example is attached to this report.

Server: Debian etch
Php: 5.2.0-8etch11
(issue imported from #M9491)


Files

original content.txt (5.27 KB) original content.txt Administrator Admin, 2008-10-06 10:53
generated page.txt (29.3 KB) generated page.txt Administrator Admin, 2008-10-06 10:54
#1

Updated by Pierrick Caillon over 12 years ago

More information:
- typo3 4.2.1

#2

Updated by Oliver Hader over 12 years ago

What exactly do you mean by "messed up"? Is it about the special french characters (e.g. like "ĂȘtre")?

#3

Updated by Pierrick Caillon over 12 years ago

No, if you compare the two file, you can notice that some text and tags are missing from the provided content.
For example, one case is that we have this in the content element :
<h3>my title</h3>
and we obtain :
<h3>my title&lt;/h3&gt;

Another instance is :
Yeah, let's go with that <b>text</b>.
changed to
o with that <b>text</b>.

or like that.

The original content file provide the bodytext record data of the miss converted content.
The generated page contains the content of the cache for the page containing the content element provided just before.

I am using templavoila for template.

#4

Updated by Juha Tiensyrja almost 12 years ago

I seem to have the same problem: some tags are randomly changed from normal tags to entity versions (i.e. those that have & lt ; or something similar).

This also happens in random pages most commonly with link tags, which prevent us from having working links to outside pages. Clearing the cache and reloading pages makes the problem sometimes disappear only to return after some random time.

This bug is annoying me out of my mind, so if I can provide any additional information I would be glad to help!

Typo3 version is 4.2.6 and PHP version is 5.2.6.

#5

Updated by Juha Tiensyrja almost 12 years ago

I might have resolved this problem by disabling config.xhtml_cleaning = all in the template. At least after that I haven't received any malformed pages.

EDIT: I'm sorry, it actually didn't help. It however changed the pages on which this problem occurs. And it seems to have fixed another small problem with tt_news plugin.

#6

Updated by Alexander Opitz almost 8 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#7

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF