Bug #19433

HTML tags are removed in RTE content

Added by Bartosz Koczorowski about 13 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-10-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I created text in rtehtmlarea with bold and italic format. I put there image too. When I saving my work RTE is removing all this formats and image putting instead html code without <> bracket.

For example:

lt;base href=http://myadress.com/typo3/ /gt; img style=width: 108px; height: 91px; src=uploads/RTEmagicC_48dfc2e731.jpg.jpg alt= / btext/b br /link http://myadress.coml/cat/?id=13 _top internal-link /link

TYPO3 ver. 4.2.1
rtehtmlarea ver. 1.7.5
(issue imported from #M9514)


Related issues

Is duplicate of TYPO3 Core - Bug #19338: XML Problems with PHP5 and libxml 2.7.1ClosedSteffen Kamper2008-09-16

Actions
#1

Updated by Stanislas Rolland about 13 years ago

Remove whatever you have put in Page TSConfig.

#2

Updated by Dominik Stankowski about 13 years ago

I can confirm the bug for all Flexible Content Elements using the RTE. As we did not update TYPO3 or the RTE since the problem appears, it might be connected to TemplaVoilà which we have updated since...

All extensions: latest versions from TER

#3

Updated by Bartosz Koczorowski about 13 years ago

I removed everything from Page TSConfig, problem still appears. More information about my server enviroment (maybe it will help):
- Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8b mod_bwlimited/1.4 PHP/5.2.6
- mySQL 5.0.51a

#4

Updated by Stanislas Rolland about 13 years ago

@Bartosz: what type of content element are you editing? And is the content correct in the database?

#5

Updated by Stanislas Rolland about 13 years ago

I cannot address this issue without more information. The RTE transformation seems to be broken by some extension or Page TSConfig.

#6

Updated by Bartosz Koczorowski about 13 years ago

Sorry for delay. I have installed TV and RTE. I create page content (text) in Rich Text Editor and then problem appears. I have no information about errors in database. Stanislas, if you want to see this, I can give you access to this website TYPO3. Then it will be easier to describe solution of this problem here. My e-mail address ()

#7

Updated by Stanislas Rolland about 13 years ago

This is not a htmlArea RTE issue. Saving text works fine in standard content elements. Also, the problem exist the same way in flexible content elements if you use alternative RTE.

Sorry, I do not understand why templavoila is protecting all html tags.

I will move this issue to templavoila where it seems to belong. Perhaps you may get support from the English user list of from the templavoila user list.

#8

Updated by Gregor Gold about 13 years ago

Hi everyone,

we did experience the same problem today, as no RTE content, which was entered via an FCE and Templavoila, was rendered in the frontend correctly. Instead, the system did output all tags with the < and > brackets stripped of.

Reason was an server update our provider did do this morning. And one of the server components updated was libxml2, which was updated from 2.6.30 to 2.7.2. This caused the problems, as parsing of characters like &,<,> and others could not be carried out anymore.

They did switch to libexpat, which (according to our provider) offers the same standard xml functions as libxml2 and everything works fine again.

So maybe it's not a Typo3 or Templavoila problem but a server side problem, which does/did cause your problems.

At least, maybe this information is kind of valuable for anyone who upgrades his server and faces similar problems afterwards.

#9

Updated by Dmitry Dulepov almost 13 years ago

TemplaVoila does not participate in RTE creation or editing. TYPO3 core (namely TCEforms) and RTE display forms, etc. TemplaVoila does not do it, so it is not TemplaVoila problem. I move the bug to RTE project.

#10

Updated by Christian Lerrahn almost 13 years ago

For me this problem only occurs in FCEs. The RTE in regular content elements does not break. However, in the RTE within an FCE I can only use p tags it seems. Even br tags break.

So, this seems to be somehow TemplaVoila related even though I can't tell how.

#11

Updated by Steffen Kamper almost 13 years ago

ensure in your DS of FCE that there is not the tag:
<HSC>1</HSC> - this will do a htmlspecialchars with the content.

#12

Updated by Ertan Atay almost 13 years ago

@Steffen Kamper
it does not effect if i delete the tag:
<proc type="array">
<HSC type="integer">0</HSC>
</proc>

the same problem appears.

@Gregor Gold
how can i switch from libxml2 to libexpat?

I use:
TYPO3 ver. 4.2.1
rtehtmlarea ver. 1.7.5
Operating system: Redhat Linux Fedora 9
PHP Version 5.2.6

#13

Updated by Christian Lerrahn almost 13 years ago

I can confirm what Ertan writes. HSC is set to 0 and still I have this problem.

#14

Updated by Markus Gaugusch almost 13 years ago

I stumbled across this problem too after updating from openSUSE 10.2 to openSUSE 11.1. I could work around it by downgrading libxml2 to version 2.6.32 from openSUSE 11.0, but I would really like to go back to the original version delivered with 11.1. (which is 2.7.1)

#15

Updated by Stanislas Rolland almost 13 years ago

See patch attached to issue #19338.

#16

Updated by Dmitry Dulepov almost 13 years ago

For everyone for the 100th time: TEMPLAVOILA DOES NOT CHANGE ANYTHING YOU SUBMIT WITH BE FORMS!!! TYPO3 processes forms, not TemplaVoila!!!

Please, remember this once and forever, would you? I am getting really tired of the wrong reports of this kind.

#17

Updated by Oliver Hader over 12 years ago

Please use issue #19338 for further discussion since it's an libxml2 problem.

#18

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF