Bug #19479

Enable Caching "USER" instead of "USER_INT"

Added by Sonja Schubert about 13 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
felogin
Target version:
-
Start date:
2008-10-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Felogin is a extension which is used often in the right column of every page. Because the extension is not cached, this leads to performance losses, and the whole static file cache doesn't work anymore.

There are two solutions:

1.) TypoScript condition which checks for [usergroup = *] and sets the extension to USER_INT if there is a user logged in. (Extension has to be set to USER as default)

2.) TYPO3 Core support for 'condition based caching' or something similar.
(issue imported from #M9599)


Files

9599.diff (506 Bytes) 9599.diff Administrator Admin, 2008-10-25 21:47
0009599_v3.patch (585 Bytes) 0009599_v3.patch Administrator Admin, 2008-10-27 17:00
0009599_v5.patch (555 Bytes) 0009599_v5.patch Administrator Admin, 2008-11-04 10:08

Related issues

Related to TYPO3 Core - Feature #19510: Enable includeLibs also for USER and COA objectsClosedOliver Hader2008-10-27

Actions

Also available in: Atom PDF