Bug #19644

Hidden pages become visible if

Added by Ramon Cahenzli over 10 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-11-25
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We need to enable our backend users to view pages that are restricted (via "Access" tab) to certain frontend users. Otherwise the backend users can't edit content properly as they can't see what they're doing, and creating frontend groups is not an option.

So we thought the "simulateUserGroup" feature is the perfect solution, since it's supposed to do what we want. We set this in the user's TSconfig:

admPanel {
hide=1
enable.preview=1
override.preview.simulateUserGroup=7
}

This makes the pages protected by FE access privileges visible. So far, so good. But it makes ALL pages and ALL content elements marked "hidden" visible as well. This is of course not the expected behavior.

We then tried the following monster:

admPanel {
module.preview.showHiddenPages = 0
override.preview.showHiddenPages = 0

module.preview.showHiddenRecords = 0
override.preview.showHiddenRecords = 0
enable.edit = 1
enable.preview = 1
override.preview.simulateUserGroup = 7
hide = 1
}

This has no effect, hidden pages and records are still shown. We are running 4.3.2, but the behavior was the same previously. Similar behavior was reported as fixed in 0005611, but from what we can see, we don't think it's fixed yet.

Could you confirm that the behavior is still present, and whether it's wrong or intended? If it's intended, do you have any idea how we could achieve the expected behavior?

(issue imported from #M9843)


Related issues

Related to TYPO3 Core - Bug #20524: Hide on FE-login still shows elemens in simulation mode Closed 2009-05-29
Duplicates TYPO3 Core - Bug #20335: Hidden Content Elements are displayed in the Module "View Page" Closed 2009-04-22

History

#1 Updated by Ramon Cahenzli over 10 years ago

Clarification: "Creating frontend groups is not an option" should read "creating frontend users is not an option" :)

#2 Updated by Nabil Saleh about 10 years ago

I can not reproduce this after heavy testing,
admPanel {
hide=1
enable.preview=1
override.preview.simulateUserGroup=X
}
works like a charme no hidden pages/contentelements were visible

does the problem persist, did you check you configuration, reproduce this on a clean installation?

#3 Updated by Chris topher about 10 years ago

As I understand Ramon, he uses backend-users.
They should see the content/pages etc.

If they use the module web > view to do so, this is the same issue as #20335, which I can reproduce.

#4 Updated by Nabil Saleh about 10 years ago

ok confirmed :) missed that point i'll have a look at it

#5 Updated by Nabil Saleh about 10 years ago

patch accidently added to #0010951 but as the patch works for both bugs/bugs are equal i think its ok please test as i'm not shure about possible sideeffects

#6 Updated by Chris topher about 10 years ago

Hey Nabil,

to get your patch discussed and finally included, send it to the TYPO3-core-list!

Check out:
http://typo3.org/development/bug-fixing/mailing-list/
http://typo3.org/teams/core/core-mailinglist-rules/

#7 Updated by Christian Kuhn about 10 years ago

Resolved, duplicate of #20335

Choose this issue as dupe because the other one has a better description.

#8 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF