Bug #20524

Hide on FE-login still shows elemens in simulation mode

Added by Niels Fröhling about 10 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-05-29
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As the title says. Typo3 does hide "hide on FE-login" pages though!

Logically I would consider a element that is in hidden state in that case as one of the elements which should only appear with the "Show hidden Records" option in the adminPanel. The same is for pages, the hidden pages should appear if the "Show Hidden Pages" option is set (which they don't).

In this state it's hugely inconsistent and wrong.

(issue imported from #M11213)


Related issues

Related to TYPO3 Core - Bug #20335: Hidden Content Elements are displayed in the Module "View Page" Closed 2009-04-22
Related to TYPO3 Core - Bug #19644: Hidden pages become visible if Closed 2008-11-25
Related to TYPO3 Core - Bug #17298: Frontend preview and simulate time is buggy Closed 2007-05-11
Duplicates TYPO3 Core - Bug #17384: simulate Backend Group shows always hidden pages and records Closed 2007-06-13

History

#1 Updated by Chris topher about 10 years ago

This is the same as #17384.

It seems to be somehow connected to #20335, #19644, #17298.

#2 Updated by Niels Fröhling about 10 years ago

Yes, seem to have creeped up all at the same time. :)

I suggest to consider the proposed logic and respect the "Show ..." settings of the adminPanel instead of making an ad-hoc "show-all or hide-all on condition".

#3 Updated by Christian Kuhn about 10 years ago

This is only true for the Web->View module, right?

#4 Updated by Niels Fröhling about 10 years ago

Yes.

#5 Updated by Niels Fröhling about 10 years ago

I don't know if this is an additional bug:

While investigating how I can teach enableFields() to declare "show on not logged in" content elements hidden in the presence of feGroup-simulation, I detected that a BE-user which has no workspaces enabled, sees the 'Preview of workspace "" (0)' message in his Web->View ... that also means that $this->versioningPreview is set, which kills all enableFields()-restrictions!

Workspace 0 is the default workspace? If workspaces are disabled, why does it lead to superpowers regarding element-visibility?

#6 Updated by Niels Fröhling about 10 years ago

As a side-effect it means that the BE-user can't run start/stop-time simulations, because the necessary query is never extended/appended ...
Did I oversee something?

#7 Updated by Niels Fröhling about 10 years ago

Maybe this is the real question:

  • If workspaces are enabled, why does it lead to superpowers regarding element-visibility?

Why is this unconditional statement been made in the first place?:

if (!$this->versioningPreview || !$ctrl['versioningWS'] || $noVersionPreview) { // In case of versioning-preview, enableFields are ignored (checked in versionOL())

I mean intuitively a selection of a version and/or a workspace does not mean that now all is visible.? Just digging for the underlaying explanation ...

#8 Updated by Niels Fröhling about 10 years ago

I fixed the "Preview of workspace" issue in 11311
I understood now why the superpowers and I'm going to make a final patch for 10951/9843.

#9 Updated by Niels Fröhling about 10 years ago

Finally I'm going to add that the "Hide on FE-login" content elements appear with the "Show Hidden Records"-switch. Except you say no ...

#10 Updated by Alexander Opitz over 6 years ago

  • Category deleted (Communication)
  • Status changed from Accepted to Needs Feedback
  • Target version deleted (-1)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#11 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Rupert Germann)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF