Bug #19683

Extending palettes and fields to be displayed in back-end forms mixes up tabs

Added by Oliver Hader over 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-12-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

A misbehaviour in t3lib_extMgm results in missing tabs when TCA types or palettes definitions get extended. The reason is, that a duplicate check for field names does not work for "--div--" or "--palette--" which migh occur multiple times.

(issue imported from #M9897)


Files

0009897.patch (8.79 KB) 0009897.patch Administrator Admin, 2008-12-04 16:57

Related issues

Related to TYPO3 Core - Feature #19497: Integrate possibility to extend TCEforms palettes easilyClosedOliver Hader2008-10-22

Actions
Related to TYPO3 Core - Bug #20962: Field handling API in t3lib_extMgm does not check for duplicates on insertion and runs superflouos insertionsClosedOliver Hader2009-08-31

Actions
Has duplicate TYPO3 Core - Bug #19646: dividers get stripped when using method t3lib_extMgm::addFieldsToAllPalettesOfField()ClosedIngo Renner2008-11-26

Actions
Has duplicate TYPO3 Core - Bug #20178: t3lib_extMgm::addToAllTCAtypes and specific position removes tabsClosedMichael Stucki2009-03-13

Actions

Also available in: Atom PDF