Bug #19723

Default language not always honored in result list (has patch)

Added by Ralf Hettinger over 12 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2008-12-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using indexed_search in multilanguage setups with config.linkVars containing L, there exists the following glitch:
A found result hit which has sys_language_uid=0 (ie default language) won't be linked to with the right language parameter (ie L=0) from within indexed_search's result list, if the triggering search is performed with some other than the default language (ie L>0). Instead, the result will be linked to in that other language.
The reason is, that a language parameter is only applied to a result link if the result hit has sys_language_uid > 0. This is okay and indeed desired for environments without multiple languages.

To fix this behaviour, the attached patch suggests an additional TS parameter
plugin.tx_indexedsearch.forceLanguageParamInResultList = (boolean)
that forces the L parameter in result list, even if L=0.

(issue imported from #M9983)


Files

9983_4.3_alpha1.patch (802 Bytes) 9983_4.3_alpha1.patch Administrator Admin, 2008-12-19 11:49

Related issues

Has duplicate TYPO3 Core - Bug #30852: Multilingual search in translated pages: Results of default language always linking to current language Closed2011-10-12

Actions
#1

Updated by Chris topher over 11 years ago

Not sent to Core List.

#2

Updated by Ralf Hettinger over 11 years ago

Hey Christopher, thanks for kicking butts (at least mine) for more Core List interaction, that's really refreshing (and I mean it) ;)
I remember that I considered this patch not clean enough for a Core/sysext suggestion - having an additional parameter for fixing a bug seems quite odd. I admit I lost track a bit on digging deeper here.

#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Ralf Hettinger over 8 years ago

The issue is still valid for 4.7 and the "old", non-experimental version of indexed_search in 6.0+

#5

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Mathias Schreiber over 6 years ago

  • Target version set to 7.5
  • Is Regression set to No
#7

Updated by Benni Mack almost 6 years ago

  • Target version changed from 7.5 to 7 LTS
#8

Updated by Mathias Schreiber almost 6 years ago

  • Target version deleted (7 LTS)
#9

Updated by Tymoteusz Motylewski over 5 years ago

  • Status changed from New to Resolved
#10

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF