Project

General

Profile

Actions

Bug #30852

closed

Multilingual search in translated pages: Results of default language always linking to current language

Added by Florian Busch (floxx) over 12 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
Start date:
2011-10-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If indexed_search is configured to list search results from all languages on one page...

plugin.tx_indexedsearch._DEFAULT_PI_VARS.lang >

...and you're searching on translated page (with i.e. &L=1 as param) every result from default language links to current linkVar (in this case &L=1).

That's because function linkPage() from class.tx_indexedsearch.php calls pi_linkToPage() without linkVars if result is from default language. So the current linkVar will be appended in function linkData() of class.t3lib_tstemplate.php which results in defaul language result, linking to current, translated language.

Diff appended.


Files

bug_indexed_search.diff (608 Bytes) bug_indexed_search.diff Florian Busch (floxx), 2011-10-12 17:13

Related issues 4 (1 open3 closed)

Related to TYPO3 Core - Bug #81164: Indexed Search appends ?L=0 to URLs of search resultsClosed2017-05-07

Actions
Related to TYPO3 Core - Bug #81986: indexed_search generates duplicated results for same pageNew2017-07-27

Actions
Related to TYPO3 Core - Bug #81994: Indexed Search Bugfix #30852 messes with Realurl cacheClosed2017-07-28

Actions
Is duplicate of TYPO3 Core - Bug #19723: Default language not always honored in result list (has patch)Closed2008-12-19

Actions
Actions #1

Updated by Oliver Hader about 11 years ago

  • Target version set to 2222
Actions #2

Updated by Oliver Hader about 11 years ago

  • Project changed from 1382 to TYPO3 Core
Actions #3

Updated by Oliver Hader about 11 years ago

  • Category set to Indexed Search
Actions #4

Updated by Oliver Hader about 11 years ago

  • Target version deleted (2222)
Actions #5

Updated by Mathias Schreiber over 9 years ago

  • Status changed from New to Accepted
  • Target version set to 7.5
  • TYPO3 Version set to 4.5
  • Is Regression set to No
Actions #6

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 8 LTS
Actions #7

Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47476

Actions #8

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47482

Actions #9

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47482

Actions #10

Updated by Tymoteusz Motylewski about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #11

Updated by Christian Toffolo over 7 years ago

This change adds "L=0" also to results in default language and this consequently messes with Realurl cache.

Actions #12

Updated by Jan Rödig almost 7 years ago

Christian Toffolo wrote:

This change adds "L=0" also to results in default language and this consequently messes with Realurl cache.

This. Would be ace to have a typoscript config option to turn this off!

Actions #13

Updated by Mona Muzaffar almost 7 years ago

  • Related to Bug #81164: Indexed Search appends ?L=0 to URLs of search results added
Actions #14

Updated by Mona Muzaffar almost 7 years ago

  • Related to Bug #81986: indexed_search generates duplicated results for same page added
Actions #15

Updated by Mona Muzaffar almost 7 years ago

  • Related to Bug #81994: Indexed Search Bugfix #30852 messes with Realurl cache added
Actions #16

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF