Bug #20759

Changing the workspace by the workspace selector produces JavaScript errors

Added by Oliver Hader almost 12 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
-
Start date:
2009-07-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On changing the workspace from e.g. live to draft by using the workspace selector, JavaScript errors appear. Firefox can handle them without any problem, however Internet Explorer has some severe problems with it.

Solution:
When the workspace got changed the selector puts a location.href to the top of the backend.php's JavaScript. It's preferred to use a real HTTP redirect instead of the JavaScript hack.

(issue imported from #M11541)


Files

0011541_4-2.patch (1.16 KB) 0011541_4-2.patch Administrator Admin, 2009-07-15 17:26
#1

Updated by Sonja Schubert about 10 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee changed from Oliver Hader to Tolleiv Nietsch
  • Target version deleted (-1)
#2

Updated by Tolleiv Nietsch almost 10 years ago

Why is that waiting for feedback?

#3

Updated by Michael Klapper almost 10 years ago

  • Status changed from Needs Feedback to Closed

Since we have the new WS UI this issue is no longer relevant.

#4

Updated by Michael Stucki over 7 years ago

  • Category set to Workspaces
#5

Updated by Michael Stucki over 7 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF