Bug #21111

TYPO3 4.3-dev

Added by Stefan Froemken over 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2009-09-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In extension manager->language settings I get following error when I
choose a language and click on save:

Warning: strcmp() expects parameter 2 to be string, array given in
C:\xampp_webserver\htdocs\t3lib\class.t3lib_befunc.php on line 2909

I found this row:

if (is_array($CHANGED_SETTINGS) && isset($CHANGED_SETTINGS[$key]) &&
strcmp($settings[$key], $CHANGED_SETTINGS[$key])) {

and changed it with

if (is_array($CHANGED_SETTINGS) && isset($CHANGED_SETTINGS[$key]) &&
strcmp($settings[$key], (string)$CHANGED_SETTINGS[$key])) {

now it works.

TYPO3 current trunk 4.3-dev on PHP 5.3.0 on XAMPP 1.7.2
(issue imported from #M12024)


Related issues

Is duplicate of TYPO3 Core - Bug #20949: Saving translation: strcmp() expects parameter 2 to be stringClosedFrancois Suter2009-08-28

Actions
#1

Updated by Steffen Gebert over 11 years ago

duplicate of #20949

#2

Updated by Oliver Hader over 11 years ago

Dupicate of issue #20949 - please continue there...

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF