Bug #21227

Section "Help" is shown even with no subelements

Added by Georg Ringer about 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since 4.3. it is possible to hide all elements of the "Help" module which is really great but if no sub element is rendered the headline shold also not be rendered.

The headline is clickable and loads the very stange file "typo3/dummy.php"

(issue imported from #M12179)


Files

hide-empty-menu.diff (2 KB) hide-empty-menu.diff Administrator Admin, 2009-10-16 19:49
12179_v2.diff (2.24 KB) 12179_v2.diff Administrator Admin, 2010-02-21 21:57

Related issues

Related to TYPO3 Core - Bug #21975: Web->Function: empty frame if all related ext removedClosed2010-01-17

Actions
Related to TYPO3 Core - Bug #24088: Deactivating all help-modules causes a new dummy entry in "HELP" menuClosed2010-11-16

Actions
Related to TYPO3 Core - Bug #24130: Help Section is shown in Main Menu although all extensions were deactivatedClosedErnesto Baschny2010-11-18

Actions
#1

Updated by Chris topher about 12 years ago

Hi Georg,

thank you for your fix!

I also noticed this problem; this is a duplicate of #21072.

#2

Updated by Georg Ringer about 12 years ago

ah damn, it seems I overlooked something ...

can you please check the patch and report in the core list if it works? thanks

#3

Updated by Chris topher about 12 years ago

Hi Georg,

since the newsgroup-server is unavailable till sunday, let's continue here:

Your patch correctly hides empty modules.
But there is one problem with this:

There are some extensions (e.g. llxmltranslate) which create modules with no submodule in it.
These are now hidden too, so that you cannot use these extensions any longer.

I think it is illogical that there are modules without submodule, but as long as this is not changed, your patch will have to be adjusted.
I think it would be enough to just check for the help module and to remove that, if it is empty.

#4

Updated by Georg Ringer about 12 years ago

IMO that makes no sense for me cause those kind of hacks are not very nice. I guess it is best to wait for newsgroups to be back and discuss that in the general list

#5

Updated by Chris topher about 12 years ago

What do you propose?

#6

Updated by Georg Ringer about 12 years ago

hide main title if no sub module is there

#7

Updated by Chris topher about 12 years ago

Yes, as I wrote: That is the logical solution.

But you cannot introduce it as long as there are extensions illogically using empty submodules (like llxmltranslate) or you will break them.

But we want to solve this "empty-module"-thing now, right?
Another idea: What, if you add the help module to the list "Access rights" > "Modules" in the user-settings.
See here: http://bugs.typo3.org/file_download.php?file_id=8362&type=bug
Than it could be deactivated and we would not need to wait until existing extensions are adjusted.

#8

Updated by Steffen Kamper over 11 years ago

committed to trunk rev 6958

#9

Updated by Susanne Moog over 10 years ago

  • Target version deleted (4.4.0)
#10

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#11

Updated by Wouter Wolters almost 7 years ago

  • Description updated (diff)
  • Status changed from Under Review to Resolved
  • Is Regression set to No
#12

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF