Bug #21627

Install tool password not accepted when PHP safe mode is enabled

Added by Alban Cousinie almost 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2009-11-20
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

When installing the 4.3 RC1 today, I could not log in to the install tool on my system using the password form. The default password joh316 would not get accepted. I have modified class.tx_install.php to echo the password transmited and $p was void, so the passord was not forwarded using POST. Adding the field password in the URL as a GET parameter was working though.

After many testing, I figured out disabling PHP safe mode solved the problem.
I don't know why it would block the field. Maybe just because it is named 'password'...

(issue imported from #M12685)


Related issues

Related to TYPO3 Core - Bug #21335: Knowing the md5 hash of the password, it is possible to gain access to the install tool Closed 2009-10-22
Duplicated by TYPO3 Core - Bug #17104: Install Tool does not work when using the right password Closed 2007-03-09

History

#1 Updated by Georg Ringer almost 10 years ago

i had this once too with beta3 and safemode enabled! - so confirmed

#2 Updated by Oliver Hader almost 10 years ago

Did this occur with TYPO3 4.2 or is it a new 4.3 issue?
Georg, did you investigate further and how did you solve it?

#3 Updated by Henrik Ziegenhain almost 10 years ago

I can confirm this for an updated TYPO3 4.2.10 too.

Current solution: The client disabled safe_mode

#4 Updated by Oliver Hader almost 10 years ago

I could not reproduce this with PHP 5.2 on Mac OS X and safe_mode enabled.
Besides that, using safe_mode is deprecated in PHP 5.3 and will be removed completely with PHP 6.

#5 Updated by Markus Timtner over 9 years ago

I can confirm this behavior too for TYPO3 v4.3.3 running on Linux with php 5.2.9. No Install Tool Login possible. Small workaround to this is to include the paassword in the url, like /typo3/install/index.php?TYPO3_INSTALL[type]=config&password=joh316

#6 Updated by Federico about 9 years ago

Same issue here with typo3 v 4.4.2 on opensuse linux.
thanks markus for the quik solution.

#7 Updated by Andreas Wolf about 8 years ago

  • Category set to Install Tool
  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Complexity set to easy

Any news on that?

#8 Updated by Wouter Wolters over 6 years ago

  • Status changed from Needs Feedback to Closed

Safe mode is deprecated and is not supported in TYPO3 CMS. Closed.

Also available in: Atom PDF