Bug #22127

FORM: validateForm fails if a label contains a comma

Added by Daniel Nienhaus over 9 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-02-16
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If a standard-mailform contains several required fields with commas in the label validateForms() in t3lib/jsfunc.validateform.js is not able to process them all or display the correct error-message.
This is due to a change in the FORM method in typo3/sysext/cms/tslib/class.tslib_content.php. Up to and including Version 4.2.9 the parameters ($fieldlist-array) for validateForms() where passed through rawurlencode(), now the raw data is passed, including unencoded commas. validateForms() uses commas to separate the field to check from the field-label to display on error, and does not like unencoded commas in the label.

(issue imported from #M13556)

patch13556.diff View (2.02 KB) Administrator Admin, 2010-05-21 13:15

History

#1 Updated by Georg Nebel over 9 years ago

A possible solution might be to use '|' instead of comma as a separator.

#2 Updated by Chris topher about 9 years ago

Hi Georg,

I just noticed your patch, because I read the Bugs-Newsgroup.
That was just luck.

When you have a patch for an issue, you should instead post it as an RFC to Core List. Then it will be integrated in the next releases.
Check http://typo3.org/teams/core/core-mailinglist-rules

#3 Updated by Georg Nebel about 9 years ago

Hi Christopher,
Thanks for the info.

Patch posted as RFC.

#4 Updated by Susanne Moog about 8 years ago

  • Status changed from Needs Feedback to Accepted
  • Target version deleted (0)
  • TYPO3 Version set to 4.4

#5 Updated by Maik Matthias over 6 years ago

This bug still exists in Version 4.5.x and is very annoying.

#6 Updated by Mathias Schreiber over 4 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

Also available in: Atom PDF