Project

General

Profile

Actions

Bug #22167

closed

Automatic scrolling of editing form when inserting paragraph

Added by Christian Hennecke about 14 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2010-02-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Entering a new paragraph leads to automatic scrolling of the editing form in the backend if the cursor is positioned in the last line of the visible editing area of the RTE and the editing form exceeds the browser window (i.e., it has a vertical scrollbar). The top of the RTE editing area is positioned at the top of the form, making the RTE button bars above it invisible. Also, the text inside the editing area is repositioned so the new paragraph is in the first line.

Steps to reproduce:

1. Make sure you have an editing form that is large enough, e.g., disable the use of tabs for tt_news or resize the browser window accordingly.
2. Create a new record. If you disabled tabs for tt_news, create a news record.
3. Insert a longer text in the RTE.
4. Scroll the RTE content so that there is some text left below the last visible line of the editing area.
5. Position the cursor in the last visible line of the text.
6. Press Enter.

The problem occurs with Firefox 3.5.8 and Opera 10.10 on Linux, but NOT with IE8. Other browsers have not been tested.

This effect is very confusing for the editors and you have to manually scroll the form to use the RTE buttons again.

(issue imported from #M13631)


Files

rtehtmlarea_bugfix_13631_typo3_4-3.patch (391 Bytes) rtehtmlarea_bugfix_13631_typo3_4-3.patch Administrator Admin, 2010-02-23 15:55
cmd_dummy_0.0.0_201502271548.zip (17.7 KB) cmd_dummy_0.0.0_201502271548.zip CMD Dummy extension to see the RTE bug Christophe Monard, 2015-03-05 09:59
Actions #1

Updated by Stanislas Rolland about 14 years ago

Please try the attached patch. Let me know if this is better. Not sure why this scrolling was there...

Actions #2

Updated by Christian Hennecke about 14 years ago

Sorry, the new behavior is also problematic since you can't see the cursor any more after pressing Enter. The content of the editing area should be scrolled so the cursor is visible, but not the form as a whole.

Actions #3

Updated by Stanislas Rolland over 12 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Target version deleted (0)
  • TYPO3 Version set to 4.4
Actions #4

Updated by Alexander Opitz about 9 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.7)?

Actions #5

Updated by Christophe Monard about 9 years ago

Alexander Opitz wrote:

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.7)?

Hi,

Yes the issue still exist (http://forum.typo3-fr.org/topic/22784-rte-et-saut-de-page-vers-le-bas/)

See the screencast for the effect : http://screencast.com/t/OShgClIEv8wp

Thorfin

Actions #6

Updated by Christophe Monard almost 9 years ago

I prepare a small simple dummy extension that create a table including some fields and 2 RTE in the middle and near the bottom.

If you start writing in and do a lot of text and a lot of return (you should write enough text to make the RTE starting to scroll and display the scroll bar), the screen should start to go crazy and scroll most of the time to the bottom of the entire page (the edit iframe).

The bug cannot be reproduce in IE, but appear on Chrome, FF, Safari as well. (didn't try in Opera)

I'll try to make another video more detailled in the futur.

Thorfin

Actions #7

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37894

Actions #8

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37895

Actions #9

Updated by Stanislas Rolland almost 9 years ago

  • Target version set to next-patchlevel

Please test the proposed change on TYPO3 6.2 or master.

Actions #10

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37894

Actions #11

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37894

Actions #12

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37895

Actions #13

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37895

Actions #14

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37895

Actions #15

Updated by Stanislas Rolland almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF