Bug #22299

Opening website frontend view from backend does not work properly

Added by Oliver Hader about 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-03-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The view icon in the backend to open a specific page of the website frontend does not work properly:
1) If the current backend domain (e.g. editor.mydomain.com) is not configured in sys_domain but another domain is defined for the current page to be view - the more specific domain is not used at all
2) If a specific domain is used for a page to be viewed and TYPO3 is installed in a sub-directory, this sub-directory is not considered at all

(issue imported from #M13861)


Files

0013861.patch (1.83 KB) 0013861.patch Administrator Admin, 2010-03-18 17:37

Related issues

Related to TYPO3 Core - Bug #19430: Workspace preview link - multidomainClosedBenni Mack2008-10-07

Actions
Related to TYPO3 Core - Bug #20801: t3lib_beFunc::viewOnClick - Exctract logic to find the right frontend domainClosedBenni Mack2009-07-31

Actions
Related to TYPO3 Core - Bug #22235: "Show" clickmenu in page tree generates wrong URLClosedErnesto Baschny2010-03-04

Actions
#1

Updated by Markus Klein over 10 years ago

Oliver, can you please try to get this one fixed? (at least for 4.5)
I don't think this is a minor issure, but rather a major one.

Using the View button in the BE is a frequently used function for editors and it's really annoying if its not working. (especially when having T3 in a subdirectory)

Thx a lot

#2

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Oliver Hader)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF