Bug #19430

Workspace preview link - multidomain

Added by Michael Klapper almost 13 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2008-10-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Domain records from the rootline are not taken into account when the workspace-previewlinkink is created. Only "t3lib_div::getIndpEnv('TYPO3_SITE_URL')" is used instead which will lead to serious problems in multidomain evironments.

See Patch in Attachment...

(issue imported from #M9508)


Files

0009508.workspace.preview-link-multidomain.20081007.patch (1.71 KB) 0009508.workspace.preview-link-multidomain.20081007.patch Administrator Admin, 2008-10-07 17:26
0009508_v2.patch (1.51 KB) 0009508_v2.patch Administrator Admin, 2009-07-31 11:58
9508_v3.patch (2.83 KB) 9508_v3.patch Administrator Admin, 2010-10-17 14:21
9508_v3_44.patch (2.81 KB) 9508_v3_44.patch Administrator Admin, 2010-10-17 14:21

Related issues

Related to TYPO3 Core - Bug #20801: t3lib_beFunc::viewOnClick - Exctract logic to find the right frontend domainClosedBenni Mack2009-07-31

Actions
Related to TYPO3 Core - Bug #22299: Opening website frontend view from backend does not work properlyClosed2010-03-18

Actions
Related to TYPO3 Core - Bug #24370: Generating preview link not working since Update to 4.4.5ClosedFrancois Suter2010-12-20

Actions
#1

Updated by Michael Klapper about 12 years ago

The patch "0009508_v2.patch" is the latest one wich support also the preview complete WS button.

Based on the patch "0011608: t3lib_beFunc::viewOnClick - Exctract logic to find the right frontend domain "

#2

Updated by Benni Mack almost 11 years ago

committed to trunk (rev. 9367)
committed to TYPO3_4-4 (rev. 9368)

#3

Updated by Susanne Moog over 10 years ago

  • Target version deleted (4.5.0)
#4

Updated by Michael Stucki almost 8 years ago

  • Category set to Workspaces
#5

Updated by Michael Stucki almost 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF