Bug #22471

Automatic line breaks in GIFBUILDER occur after characters like ' % ...

Added by Jack Skaba about 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2010-04-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

problems with regexp in

protected function getWordPairsForLineBreak($string)
in file class.t3lib_stdgraphic.php

$wordsArray = preg_split('#([ -.,:]+)#', $string, -1, PREG_SPLIT_DELIM_CAPTURE);

should probably be
$wordsArray = preg_split('#([ \-.,:]+)#', $string, -1, PREG_SPLIT_DELIM_CAPTURE);

#([ -.,:]+)#
the dash should be escaped otherwise it matches all characters between Space and dot like ! " # $ % & ' ( ) * + , - .
to reproduce it - just i.e. print_r(&wordsArray) and use one of the characters above in Gifbuilder (for example d'Artagnan).
(issue imported from #M14132)


Files

14132_trunk.patch (653 Bytes) 14132_trunk.patch Administrator Admin, 2010-05-11 15:20

Related issues

Related to TYPO3 Core - Feature #20164: Integrate automatic line breaks in GIFBUILDERClosedOliver Hader2009-03-11

Actions
#1

Updated by Jack Skaba about 11 years ago

this is just a reminder or a question - is there anything wrong with the description of the problem or the solution? If yes, I'm more than willing to explain it in detail. If not - could someone please put that one backslash into svn to solve that bug :) .

#2

Updated by Jigal van Hemert about 11 years ago

Pending in core list...

#3

Updated by Stefan Neufeind over 10 years ago

Checked against 4.5.2. Patch seems to be at least in that branch already. Resolved? Or might it still need backporting to other branches?

#4

Updated by Jigal van Hemert over 10 years ago

Committed to trunk (that was 4.4) in rev 7939 by Susanne on 16-06-2010 21:34.

Issue wasn't closed by mistake. Fix is present in 4.4.0-RC2 and later.

#5

Updated by Susanne Moog about 10 years ago

  • Target version deleted (4.4.0)
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF