Bug #23902

Dependency error when installing extensions on alpha or beta version

Added by Ben van 't Ende about 11 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-11-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When you install an extension in an alpha or beta version you always get an error like below:

=========================
Dependency Error

The running TYPO3 version (4.5.0alpha3) is lower than required (4.5.0).
[ ] Ignore this version requirement =========================
Checking the ignore box makes it work, but the error message should not be there.

(issue imported from #M16203)


Related issues

Related to TYPO3 Core - Bug #21952: Using TYPO3_version with "xxx-dev" won't be parsed correct in EMClosedSteffen Kamper2010-01-13

Actions
Related to TYPO3 Core - Task #54512: Bypass compatibility check in extension managerClosedNicole Cordes2013-12-19

Actions
Has duplicate TYPO3 Core - Bug #55758: Extension Manager: unable to install Ext in 6.2 betaClosed2014-02-07

Actions
Has duplicate TYPO3 Core - Feature #54521: make beta-testing simplerClosed2013-12-19

Actions
Has duplicate TYPO3 Core - Bug #54493: can't install/configure extensionsClosed2013-12-18

Actions
#1

Updated by Chris topher about 11 years ago

Having a look at #21952 this issue should have been solved there.
But seems like it wasn't or got broken again.

#2

Updated by Chris topher about 11 years ago

The reason for this not working correctly is in typo3/sysext/em/mod1/class.em_index.php:
There checkDependencies() checks for TYPO3_version containing "-alphaX", "-betaX" or "-RCX" and replaces this with "0".

This is wrong, because in alpha, beta and RC releases TYPO3_version is set to something like "4.5.0alphaX". So the replacing won't take place.

The fix is to check for TYPO3_version containing something like "alphaX" (always without the "-" at the beginning) and to remove that without replacing it with anything.

#3

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by d.ros no-lastname-given almost 8 years ago

Yes. Someone in the IRC came up with this. on a 6.2b4 with 6.1.0-6.2.99 requirement

#5

Updated by d.ros no-lastname-given almost 8 years ago

But with the newer versions it´s coming from #54521

#6

Updated by Alexander Opitz almost 8 years ago

Yes, thats another issue.

#7

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27509

#8

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27509

#9

Updated by Gerrit Code Review almost 8 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27509

#10

Updated by Jigal van Hemert almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by joujou no-lastname-given almost 8 years ago

I still have the problem : Your TYPO3 version is lower than necessary. You need at least TYPO3 version 6.2.0
I have Typo3 6.2 beta 5.

#12

Updated by Fabian Thommen almost 8 years ago

Same here, deinstalling "lowlevel" and reinstalling it, gives this error. I have Typo3 6.2 beta 5.

Typo3 6.2 beta 5 still contains this error.

But as I understand, this will be fixed in 6.2 beta 6. or 6.2 final?

#13

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF