Bug #24310

TCEForm select dropdowns have text overlapping icon in Webkit

Added by Jeff Segars over 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-12-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using the select dropdown for pages, content elements, etc in Webkit, the item text overlaps the icon.

Since form styling (especially selects) is horribly inconsistent between browsers, the best option I've found is to target Webkit specifically with a class already applied by ExtJS.

(issue imported from #M16702)


Files

16702.diff (561 Bytes) 16702.diff Administrator Admin, 2010-12-08 21:19
Before.png (3.44 KB) Before.png Administrator Admin, 2010-12-08 21:20
After.png (3.35 KB) After.png Administrator Admin, 2010-12-08 21:20

Related issues

Related to TYPO3 Core - Bug #24579: Double class attribute for select tag of tceforms "type=select" if using iconsClosedChristian Kuhn2011-01-14

Actions
Has duplicate TYPO3 Core - Bug #24544: Page type icon mixes with text in page settings dropdown in Webkit browsersClosedSteffen Gebert2011-01-13

Actions
#1

Updated by Jeff Segars over 10 years ago

Commited to trunk in r10213

#2

Updated by Susanne Moog about 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF