Bug #24515

alt_doc.php does not keep default values given in URL.

Added by Pierrick Caillon over 10 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2011-01-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The defVals url parameter is undefined after first saving of the record.
When using the "save and new" button, the behaviour I expected was to provide again these default values. However TYPO3 unsets them and they are no more available.

This behaviour is understandable in the case the other buttons are used. it saves little bandwith, processing and memory.

File typo3/alt_doc.php line 262
unset($this->R_URL_getvars['defVals']);

(issue imported from #M16969)


Related issues

Related to TYPO3 Core - Bug #85633: "Save and create a new one" button in BE appends superfluous hash which resets defValsClosed2018-07-24

Actions
#1

Updated by Alexander Opitz about 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.3)?

#2

Updated by Pierrick Caillon about 7 years ago

Hello,
The issue still exists in 6.2.3. It has moved at there : typo3/sysext/backend/Classes/Controller/EditDocumentController.php on line 552.
The line content is the same.

#3

Updated by Alexander Opitz about 7 years ago

  • Category set to Backend API
  • Status changed from Needs Feedback to New
#4

Updated by Riccardo De Contardi over 5 years ago

same line of code is still present in both 6.2.15 and 7.6-dev (latest master)

#5

Updated by Riccardo De Contardi about 4 years ago

same line of code is still present in 8.7.1-dev (latest master)

#6

Updated by Susanne Moog over 1 year ago

  • Status changed from New to Closed

While the code is still present, the issue isn't as there are no "Save + New" Buttons anymore in the normal edit forms of TYPO3. Using the most similar way of creating a new record (open any record, press new) the default values are taken into account now.

#7

Updated by Georg Ringer about 1 year ago

  • Related to Bug #85633: "Save and create a new one" button in BE appends superfluous hash which resets defVals added

Also available in: Atom PDF