Bug #24936

OpenID does not work with https on VeriSign OpenIDs

Added by Oliver Hader over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2011-02-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using OpenID to log into the backend of TYPO3 does not work with an OpenID of VeriSign that uses the https protocol.

Does not work: https://username.pip.verisignlabs.com/
Works: http://username.pip.verisignlabs.com/

(issue imported from #M17455)


Related issues

Related to TYPO3 Core - Bug #21040: OpenID login does uses cURL even if was not defined in TYPO3_CONF_VARSClosedOliver Hader2009-09-12

Actions
#1

Updated by Chris topher over 9 years ago

  • Target version changed from 4.6.0 to 4.6.1
#2

Updated by Dmitry Dulepov over 9 years ago

Tried to register there to reproduce the error. Getting errors everytime when trying to register:

---
An Unexpected Problem Has Occurred
Click Return Home to return to the Personal Identity Portal home page and try the action again.
---

Can't check the issue :(

#3

Updated by Chris topher over 9 years ago

  • Target version changed from 4.6.1 to 4.6.2
#4

Updated by Felix Nagel over 9 years ago

I did some tests with OpenID and was not able to reproduce this issue. Please see here (and feel free to add some more test in the spreadsheet):
https://docs.google.com/spreadsheet/ccc?key=0AoeFGgKVpeJsdHJ6eW1rUGdrRHVzNDQ0N2J2VzdNR1E

To be sure Ive tested the https problem additionally with two different VeriSign users on 5 TYPO3 installations. Without any problems.

#5

Updated by Steffen Gebert over 9 years ago

  • Category set to 1134
  • Target version deleted (4.6.2)
#6

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Also available in: Atom PDF