Bug #25398

TCEforms draws huge empty icon row which on select-fields, making a scrollbar to appear

Added by Ernesto Baschny over 8 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2011-03-25
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Certain fields of type "select" which offer records from a "foreign_table" will contain a huge amount of t3-icon-empty icons just below the select box. If you have enough of them, you even get a horizotanl scrollbar.

See some screenshots here:
http://forge.typo3.org/issues/13422

The issue is not a CSS issue, but a bug in the rendering of such a field.

See it in action in tt_content field "sys_language". Just create enough sys_language records so that you see the row of empty icons being created. This wasn't this way before.

(issue imported from #M18041)

Associated revisions

Revision 17e41aba (diff)
Added by Benni Mack about 8 years ago

[BUGFIX] TCEforms draws huge empty icon row which on select-fields

Certain fields of type "select" which offer records from a
"foreign_table" will contain a huge amount of t3-icon-empty
icons just below the select box. If you have enough of them,
you even get a horizotanl scrollbar.

See some screenshots here:
http://forge.typo3.org/issues/13422

The issue is not a CSS issue, but a bug in the rendering
of such a field.

See it in action in tt_content field "sys_language". Just create
enough sys_language records so that you see the row of empty
icons being created. This wasn't this way before.

Change-Id: I664400ee6ee1d778e227b1858f79b9ed98482d0a
Resolves: #25398
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/5569
Reviewed-by: Stefan Galinski
Tested-by: Stefan Galinski
Reviewed-by: Dmitry Dulepov
Tested-by: Dmitry Dulepov

Revision 03f137b7 (diff)
Added by Benni Mack almost 8 years ago

[BUGFIX] TCEforms draws huge empty icon row which on select-fields

Certain fields of type "select" which offer records from a
"foreign_table" will contain a huge amount of t3-icon-empty
icons just below the select box. If you have enough of them,
you even get a horizotanl scrollbar.

See some screenshots here:
http://forge.typo3.org/issues/13422

The issue is not a CSS issue, but a bug in the rendering
of such a field.

See it in action in tt_content field "sys_language". Just create
enough sys_language records so that you see the row of empty
icons being created. This wasn't this way before.

Change-Id: I2e2e59c906b2e239ba161b16aa1980f454210229
Resolves: #25398
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/7118
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

History

#1 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change I664400ee6ee1d778e227b1858f79b9ed98482d0a has been pushed to the review server.
It is available at http://review.typo3.org/5569

#2 Updated by Markus Klein about 8 years ago

  • Target version deleted (0)

Maybe related: #24591

#3 Updated by Markus Klein about 8 years ago

  • Target version set to 4.6.0-RC1

#4 Updated by Georg Ringer about 8 years ago

  • Priority changed from Should have to Must have
  • TYPO3 Version set to 4.5

#5 Updated by Steffen Gebert about 8 years ago

  • Category set to Backend User Interface
  • Status changed from New to Under Review

I agree that this should be fixed, but I don't think that this is a blocker for a release (so I tend to unset the Must have status).

#6 Updated by Benni Mack about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF