Bug #27716

Checkboxes for multiple action do not display on page-root

Added by Uwe Michelfelder over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-06-27
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When opening the workspace on the rootpage of the page tree, the checkboxes in front of the versioned elements do not appear.
Secondly the single-promote link (->) sometimes get into an area where overflow is set to hidden. (depending on how long the label of the promotion action is).
This sometimes results into a situation, where an user wether can use the checkbox to publish, nor the single element action.

Version 4.5.2

Bildschirmfoto_2011-07-06_um_16.00.32.jpg View (63.6 KB) Uwe Michelfelder, 2011-07-06 16:03


Related issues

Related to TYPO3 Core - Bug #30659: 'next stage'-button is not visible when the stage title is to long Closed 2011-10-08
Related to TYPO3 Core - Bug #31122: Checkbox for mass action didn't apear if user have only publish/swap permission Closed 2011-10-19

History

#1 Updated by Michael Klapper over 8 years ago

  • Status changed from New to Needs Feedback

hi Uwe,

Can you provide some screenshots and bit more details about your environment and how we can reproduce it.

#2 Updated by Uwe Michelfelder over 8 years ago

Attached a screenshot of the described situation.
What kind of info would you need about the environment ?
Unfortunately I could not reproduce this on another system with workspaces.

#3 Updated by Michael Klapper over 8 years ago

Hi Uwe,

thx for the update!

unfortunately im still not able to reproduce this issue on an TYPO3 4.5.3 and current master (TYPO3 4.6). I tested this on 3 different installations.

I could imaging that there is an JavaScript error on your page, because normaly the actions are not displayed on initial page load - they appear a second later.

Can you check the error console? Which Browser and version are you using?

Mick

#4 Updated by Uwe Michelfelder over 8 years ago

Hi Mick,

I checked the specific installation on Firefox5 and Chrome 12 on Mac. No errors in the console.
I checked it also on a another installation, there it works as expected.

The installation where I'm running into the problem with, has come a long way with upgrading versions over the last 4-5 years, including workspaces. Maybe some legacy data on the root page creates the problem?

Grüße,
Uwe

#5 Updated by Stefan Neufeind over 8 years ago

For the "second issue" you described, please see #30659. So we should imho ignore that additional bug here.

For the checkbox (main issue described here): Am I right that #31122 describes the same situation (and this here is a "duplicate")? If so, please try the patch over there which is currently under review.

#6 Updated by Tolleiv Nietsch about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Priority changed from Must have to -- undefined --

Duplicate without further feedback ...

#7 Updated by Michael Stucki about 6 years ago

  • Category set to Workspaces

#8 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF