Feature #27794

Limit to Languages doesn't restrict editing of page properties in default Language if "Page" modify is allowed

Added by taywa gmbh over 8 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-07-01
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

If I set "Limit to Languages" in the "Access List" not to the default language and allow "Page" under "Tables (modify)" I still can edit the page properties.

This maybe is locical correct, hence this is not a bug. But It would be better, if you set "Limit to Languages" to another then default Languages, not allow to edit the page table, because this is the goal the configuration wants to achieve.

My blog post regarding this issue, in german: http://www.netzkompetenz.ch/typo3/trotz-limit-to-language-bleibt-der-page-eigenschaften-der-default-sprache-editierbar/

edit_default_langauge.png View (65.4 KB) taywa gmbh, 2011-07-01 13:15

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.4 (Backend)

#2 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#3 Updated by Benni Mack about 4 years ago

  • Target version deleted (7.5)

#4 Updated by Riccardo De Contardi over 1 year ago

I think that this has been at least partially solved in version 9.2.0-dev (latest master).

I tried the following test

Prerequisites

1) TYPO3 with default language (ITALIAN) and two additional languages (ENGLISH, FRENCH)
2) BE group: Editors, give full access in ACL
3) Editor user (no admin), limit it to languages ENGLISH, FRENCH

Test

1) create a page and some content
2) translate the pagein in French, English and translate the content (Translate mode)
3) give the page group permissions "editors"

Results

1) in Page view > Languages you see the three languages, but the edit pencil is only with french, english
2) in Page view > columns you don't see any pencil to edit pages (!) even in FRENCH, ENGLISH - you can only edit content in FRENCH and ENGLISH
3) In List View you can't see any pencil to edit the pages(even in FRENCH and ENGLISH)
4) about the context menu that opens when clicking on the page icon:
4.1) in ITALIAN it shows all the actions, even "new" and "edit"
4.1.1) when clicking on "edit", an error is shown (operation not permitted)
4.1.2) when clicking on "new" it creates a new language with language_uid=1
4.2) in FRENCH all the actions are visibile
4.3) In ENGLISH only "show", "info", "more options", "history/undo" are visible. I don't know why (the language has id=2)

There are inconsistencies in the interface but at least it seems that the editing of the original language is forbidden.

I haven't done further tests; do you think that there are different scenarios to test?

#5 Updated by Susanne Moog 12 months ago

  • Status changed from New to Closed

This is mainly fixed since the removal of pages_language_overlay and the reworked language handling.

Also available in: Atom PDF