Bug #27971

xliff removed hook to override locallangs

Added by Georg Ringer over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2011-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There was a hook in t3lib_div::readLLFile() to override any locallang file by another one. The additional locallang is merged with the existing one which is very nice feature to override just one label.

as the l10n changed a lot with xliff, it is not just a copy paste to get hook working again.
previous hook was this

$overrides = array();
            $fileRefWithoutExtension = preg_replace('/\.(php|xml)$/', '', $fileRef);

            if (is_array($GLOBALS['TYPO3_CONF_VARS']['SYS']['locallangXMLOverride'][$fileRefWithoutExtension . '.php'])) {
                $overrides = array_merge($overrides, $GLOBALS['TYPO3_CONF_VARS']['SYS']['locallangXMLOverride'][$fileRefWithoutExtension . '.php']);
            }
            if (is_array($GLOBALS['TYPO3_CONF_VARS']['SYS']['locallangXMLOverride'][$fileRefWithoutExtension . '.xml'])) {
                $overrides = array_merge($overrides, $GLOBALS['TYPO3_CONF_VARS']['SYS']['locallangXMLOverride'][$fileRefWithoutExtension . '.xml']);
            }

            if (count($overrides) > 0) {
                foreach ($overrides as $overrideFile) {
                    $languageOverrideFileName = self::getFileAbsFileName($overrideFile);
                    if (@is_file($languageOverrideFileName)) {
                        $languageOverrideArray = self::readLLXMLfile($languageOverrideFileName, $langKey, $charset);
                        $LOCAL_LANG = self::array_merge_recursive_overrule($LOCAL_LANG, $languageOverrideArray);
                    }
                }
            }

Related issues

Is duplicate of TYPO3 Core - Bug #27923: locallangXMLOverride hook has been removedClosedXavier Perseguers2011-07-06

Actions
#1

Updated by Susanne Moog over 9 years ago

Georg is this a duplicate of #27923?

#2

Updated by Christian Kuhn over 9 years ago

  • Status changed from Accepted to Needs Feedback
#3

Updated by Christian Kuhn over 9 years ago

This was solved afaik, and the unit test that was created for the hook in the first place runs as well again.

#4

Updated by Steffen Gebert over 9 years ago

  • Status changed from Needs Feedback to Closed

Fixed with #27923

#5

Updated by Steffen Gebert over 9 years ago

  • Status changed from Closed to Needs Feedback

Well, let's wait for Georg's statement :)

#6

Updated by Steffen Gebert over 9 years ago

  • Status changed from Needs Feedback to Rejected

Closed due to no feedback

Also available in: Atom PDF