Bug #28528

inconsistency in class.t3lib_userauthgroup.php and tables.php

Added by Georg Leitner over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2011-07-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

I searched for an option to sort multiple filemounts by title and checked #22070 and #20609.

Admin Tools > Configuration > TCA revealed an option $TCA['sys_filemounts']['ctrl']['sortby'] = 'sorting'; Changing this value to 'title' doesn't have the desired effect. After a look at the code I found the right option which is $TCA['sys_filemounts']['ctrl']['default_sortby'] (default_sortby instead of sortby).

In /t3lib/stddb/tables.php $TCA['sys_filemounts']['ctrl']['sortby'] = 'sorting' is defined, but the function fetchGroupData() in /t3lib/class.t3lib_userauthgroup.php checks $GLOBALS['TCA']['sys_filemounts']['ctrl']['default_sortby'].

#1

Updated by Steffen Gebert over 9 years ago

  • Category set to Backend API
  • Complexity set to easy

Georg, could you provide a patch for that?

#2

Updated by Mario Rimann about 9 years ago

I just browsed through the code, the line reads:

$orderBy = $GLOBALS['TCA']['sys_filemounts']['ctrl']['default_sortby'] ? $GLOBALS['TYPO3_DB']->stripOrderBy($GLOBALS['TCA']['sys_filemounts']['ctrl']['default_sortby']) : 'sorting';

So I think this fallback is already built in.

@Georg: Could you tell us, whether the problem is still present in 4.7-dev or 4.6?

#3

Updated by Alexander Opitz about 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF