Bug #28686

menu generation for shortcuts on translated pages broken.

Added by Björn Pedersen about 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-08-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The shortcut change (https://review.typo3.org/#change,3413) breaks translated sites menus.

Catchable Fatal Error: Argument 1 passed to t3lib_div::implodeAttributes() must be an array, boolean given, called in /home/webmaster/frm2/typo3_src_git/typo3/sysext/cms/tslib/class.tslib_menu.php on line 1504 and defined in /home/webmaster/frm2/typo3_src_git/t3lib/class.t3lib_div.php line 1918 (More information)

t3lib_error_Exception thrown in file
/home/webmaster/frm2/typo3_src_git/t3lib/error/class.t3lib_error_errorhandler.php in line 105.

35 t3lib_error_ErrorHandler::handleError(4096, "Argument 1 passed to t3lib_div::implodeAttributes(…slib/class.tslib_menu.php on line 1504 and defined", "/home/webmaster/frm2/typo3_src_git/t3lib/class.t3lib_div.php", 1918, array)

/home/webmaster/frm2/typo3_src_git/t3lib/class.t3lib_div.php:

01916:   * @return string Imploded attributes, eg. 'bgcolor="red" border="0"'
01917:   */

01918:  public static function implodeAttributes(array $arr, $xhtmlSafe = FALSE, $dontOmitBlankAttribs = FALSE) {

01919:   if ($xhtmlSafe) {
01920:    $newArr = array();

34 t3lib_div::implodeAttributes(boolean, 1)

/home/webmaster/frm2/typo3_src_git/typo3/sysext/cms/tslib/class.tslib_menu.php:

01502:  function setATagParts() {
01503:   debug($this->I,'I');

01504:   $this->I['A1'] = 'I['linkHREF'],1).' '.$this->I['val']['ATagParams'].$this->I['accessKey']['code'].'>';

01505:   $this->I['A2'] = '';
01506:  }

reason:

linkHREF
is empty for the translated page, as the type and linkmode/target are not inherited anymore ( the alternative page lange entry has still type standard). Changing the alternative page language entry to shortcut solves this problem, but old sites may break.


Related issues

Related to TYPO3 Core - Bug #32406: Menus not working in translated pages for type "shortcut"Closed2011-12-08

Actions
#1

Updated by Thorsten Kahler about 10 years ago

  • Status changed from New to Accepted
  • Target version set to 4.6.0
  • Complexity set to hard

Did not check that but sounds reasonable.

#2

Updated by Chris topher almost 10 years ago

  • Target version changed from 4.6.0 to 4.6.1
#3

Updated by Chris topher almost 10 years ago

  • Target version changed from 4.6.1 to 4.6.2
#5

Updated by Xavier Perseguers over 9 years ago

  • Target version deleted (4.6.2)
#6

Updated by Markus Klein almost 7 years ago

  • Status changed from Accepted to Needs Feedback
  • Complexity deleted (hard)
  • Is Regression set to No

Can't reproduce this on current master (Version7).

#7

Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF