Bug #28753

Flashmessage queue does not work in FE mode

Added by Joachim Mathes almost 10 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Frontend
Target version:
-
Start date:
2011-08-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

just a question: Will issue #24203 be fixed in the 4.4 branch of TYPO3, too?

Best regards
Joachim

#1

Updated by Thorsten Kahler almost 10 years ago

  • Category set to Frontend
  • Status changed from New to Needs Feedback
  • Assignee set to Benni Mack

I'd say, based on the patch, that it's rather a feature than a bugfix.

But I leave it to the release managers to decide upon that.

#2

Updated by Joachim Mathes almost 10 years ago

The main issue is the following method of class t3lib_FlashMessageQueue:

protected static function getFlashMessagesFromSession() {
    $flashMessages = $GLOBALS['BE_USER']->getSessionData('core.template.flashMessages');
    return is_array($flashMessages) ? $flashMessages : array();
}

This is why a BE-user has to be logged-in in the Extbase (flashmessage) context. The code logic is replaced by

protected static function getUserByContext() {
    return TYPO3_MODE === 'BE' ? $GLOBALS['BE_USER'] : $GLOBALS['TSFE']->fe_user;
}

in TYPO3 4.5.3, which looks appropriate to me.

Since the public API of class t3lib_FlashMessageQueue is the same for both branches, it might be possible to just use the 4.5 variant in 4.4. This is what I do as a workaround at the moment.

Best regards
Joachim

#3

Updated by Oliver Hader almost 10 years ago

  • Target version changed from 1305 to 1341
#4

Updated by Joachim Mathes almost 10 years ago

Some further information: Extbase 1.2 seems to work perfectly fine with TYPO3 4.4. But I have to use Extbase version 1.3.0 with TYPO3 4.4.

#5

Updated by Wouter Wolters about 8 years ago

  • Status changed from Needs Feedback to Closed

4.4 is not supported anymore. Closed.

#6

Updated by Ernesto Baschny about 8 years ago

  • Target version deleted (1341)

Also available in: Atom PDF