Bug #29595

Update of a DB record via extbase fails on MSSQL

Added by Sonja Schubert over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2011-09-09
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have an extbase extension with model and repository. When I try to update an entry via extbase repositiory update() function it fails as soon as there are special umlauts in the entry.

When I overwrite the update() function in my repository and update the entry via GLOBAL_DB->execUPDATEquery it works. The field/column with the umlauts is of type varchar.

In my opinion either extbase repsitory or at the end DBAL does not respect/convert umlauts in the update.

By the way: When the update fails, a new entry is created. The add() function seems not to have the problem with umlauts...

History

#1 Updated by Xavier Perseguers over 8 years ago

  • Status changed from New to Needs Feedback

You mean you have a column in your DB with umlaut? This is totally unsane! Even if this is authorized...

#2 Updated by Markus Klein about 6 years ago

This can be closed due to no feedback within 90 days

#3 Updated by Michael Stucki about 6 years ago

  • Project changed from DBAL to TYPO3 Core

#4 Updated by Michael Stucki about 6 years ago

  • Category set to 999

#5 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No
  • TYPO3 Version set to 4.5

Also available in: Atom PDF