Bug #29779

Sometimes editor gets an permission error in workspace module

Added by Sonja Schubert over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-09-14
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Sometimes, an editor gets an permission error when trying to delete a workspace change via workspace module.

Error message is "No permission", the deletion is performed nevertheless which is OK because the editor itself creates the workspace change and is definitely allowed to do this. Only the error message is annoying.

Unfortunately I can not reproduce the error message every time, so i can not give more information at the moment. Maybe someone else has the same problem and more information?


Related issues

Related to TYPO3 Core - Bug #17065: Impossible to delete version from Live Workspace ! Closed 2007-03-01

History

#1 Updated by Stefan Neufeind over 8 years ago

Could it be this is due to insufficient permissions in the live-workspace?

Code-path for the deletion:
JS calls workspaces/Classes/ExtDirect/ActionHandler.php, deleteSingleRecord().
That has a TCA-action:
$cmd[$table][$uid]['version'] = array(
'action' => 'clearWSID'
);

This happens in version/class.tx_version_tcemain.php and the function-header of version_clearWSID() says:
"Release version from this workspace (and into "Live" workspace but as an offline version)"

#2 Updated by Tolleiv Nietsch about 8 years ago

  • Status changed from New to Needs Feedback

Any updates / patches for this upcoming?

#3 Updated by Michael Stucki about 6 years ago

  • Category changed from Bugs to Workspaces

#4 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#5 Updated by Alexander Opitz almost 6 years ago

  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.1.7)?

#6 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF