Project

General

Profile

Actions

Bug #30257

closed

new EM: Not possible to switch between extension configuration categories

Added by Helmut Hummel almost 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2011-09-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Some extensions, like saltedpassword offer different categories in the extension manager configuration.

With the new EM it is not possible to switch between them (try to switch back and forth) and when saving the configuration after trying to switch, results in a download request of the ajax.php file

Tested in FF6


Files

screenshot.png (31.5 KB) screenshot.png Steffen Gebert, 2011-10-10 19:54
Bildschirmfoto_2011-10-10_um_22.33.54.png (32.5 KB) Bildschirmfoto_2011-10-10_um_22.33.54.png Helmut Hummel, 2011-10-10 22:35
Actions #1

Updated by Xavier Perseguers almost 13 years ago

  • Status changed from New to Accepted
Actions #2

Updated by Steffen Gebert almost 13 years ago

Broken since cc99dce

Actions #3

Updated by Steffen Gebert almost 13 years ago

With an old version of EXT:enetcache I got the message

A cache with identifier "cache_enetcache_contentcache" has already been registered.

when switching categories. After updating enetcache, everything works and I can't reproduce this anymore.

Actions #4

Updated by Dmitry Dulepov almost 13 years ago

  • Status changed from Accepted to Resolved

Not reproducible with a clean TYPO3 4.6 on Oct 06, 2011.

Closing the issue. Please, reopen if the issue persist on a clean system.

Actions #5

Updated by Helmut Hummel almost 13 years ago

  • Status changed from Resolved to Accepted

I have a fresh install here and I'm able to reproduce in FF6 and FF7.

It's in the NEW Extension Manager only, not in the old modules, these work properly.

Did you try to switch back and forth between the categories of the salted password extension in the new EM? It just doesen't work!

Actions #6

Updated by Steffen Gebert almost 13 years ago

I just tried it again.. master with FF7 on MacOS and it works (you're talking of the Advanced FE/BE Categories, I think). Could you give it a try with another browser? Maybe on another PC?

Actions #7

Updated by Steffen Gebert almost 13 years ago

  • Status changed from Accepted to Needs Feedback
Actions #8

Updated by Steffen Gebert almost 13 years ago

This also fails for you with 4.5, doesn't it?

Actions #10

Updated by Helmut Hummel almost 13 years ago

I tried it with Safari 5.1 and Chrome 14 and there it works fine. (All OSX 10.5)

Yes, it also does not work with 4.5.

I also tried with a clean FF profile with no extensions.

What I found out that it works the first time, but all consecutive tries after that, instead of switching categories the form is submitted.

Actions #11

Updated by Helmut Hummel almost 13 years ago

It is a problem with nested form tags (again) which causes this strange behaviour.

Nested form tags are invalid HTML and the behaviour in different browsers is just upredictable.

Actions #12

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change Ie4e4d5f33d319467626aa4923abe07d608af9bbb has been pushed to the review server.
It is available at http://review.typo3.org/5688

Actions #13

Updated by Xavier Perseguers almost 13 years ago

  • Status changed from Needs Feedback to Under Review
Actions #14

Updated by Anonymous almost 13 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #15

Updated by Steffen Gebert over 12 years ago

  • Target version changed from 4.6.0-RC1 to 4.5.8
Actions #16

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF