Bug #30395

Page tree breaking for user with multiple DB mounts

Added by Francois Suter over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2011-09-28
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On TYPO3 4.6 site in development, I have observed that the page tree is occasionally broken for a BE user (non-admin) with several DB mounts:
  • not all DB mounts get displayed
  • some DB mounts don't expand
  • hitting the refresh icon at the top of the page tree results in an empty frame, with the following JS error in the console: "d is undefined" (the usual helpful ExtJS errors)

Log out and log in again of that user does nothing. However clicking on "Reset configuration and clear temporary data" in the User Settings module solves the issue: all DB mounts are visible again and all expand as expected. Log out and in again and the problem is back.

This happens both when doing a true login as well as when simulating the BE user via User Admin.

I'll try to dig further into this, but any hint is welcome ;-)


Related issues

Duplicates TYPO3 Core - Bug #28687: pagetree broken due to js exception Closed 2011-08-02

History

#1 Updated by Peter Niederlag over 8 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to 4.6.0

Unfortunatly I have no clue but at least I can confirm the issue

#2 Updated by Francois Suter over 8 years ago

Adding some info as I investigate the matter, in the hope that it inspires someone:
  • by looking at the JSON response, I can see that the data for the page tree is complete. It contains all the expected pages/mount points.
  • the rendering of the page tree breaks with the following error (seen in the console):
    uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMHTMLUListElement.appendChild]" nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)" location: "JS frame :: http://www.bobst.site/typo3temp/compressor/ext-all-f70e2f43e02eed157469b645035c4c02.js :: anonymous :: line 7" data: no]
    
  • in my case, the last two pages also cannot be expanded. Trying to do so triggers the same error as above.

#3 Updated by Francois Suter over 8 years ago

Running in debug mode, I can see the problem happens in method render() of Ext.tree.TreeNodeUI when trying to call appendChild() (when bulkRender is true). That's in ext-all-debug.js line 36180.

#4 Updated by Björn Pedersen over 8 years ago

Looks like it is the same as http://forge.typo3.org/issues/28687 .
I also have multiple mount points and the behaviour is the same)

#5 Updated by Francois Suter over 8 years ago

Indeed it's the same issue. It's depressing to see that no one seems to be able to solve it :-(

#6 Updated by Xavier Perseguers over 8 years ago

  • Status changed from Accepted to Closed

Fixed by related bug tracker entry.

Also available in: Atom PDF