Bug #30703

Epic #62041: twbs Bootstrap backend, refactor EXT:t3skin and HTML5 output

Epic #62836: FormEngine PHP/HTML Improvements & Bootstrap

TCA type "select" + "multiple": cannot select the same item many times

Added by Dmitry Dulepov over 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2011-10-10
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Suppose you have a select control with "multiple" property in $TCA (see the screenshot). You want to add the same item multiple times. You cannot do that by simply clicking the item multiple times: you have to click the item, the other item, again your item, and so on.

The cause: the control uses "onchange" handler. There is no "change" event when the same item is clicked.
The solution: the control should use "onclick" handler.

multiple-items.png View (17.1 KB) Dmitry Dulepov, 2011-10-10 09:53

History

#1 Updated by Xavier Perseguers over 8 years ago

  • Status changed from New to Accepted

#2 Updated by Dmitry Dulepov over 8 years ago

TCEforms uses generic code for all kind of select boxes. Therefore changing "onchange" to "onclick" should be done with care. Possibly there should be two handlers: both onchange and onclick. Onchange would work for keyboard navigation in single select boxes, onclick will work for mouse navigation in multiple select boxes.

#3 Updated by Mathias Schreiber over 5 years ago

  • TYPO3 Version changed from 4.4 to 7
  • PHP Version set to 5.5
  • Is Regression set to No

#4 Updated by Felix Kopp over 5 years ago

  • Parent task set to #62836

#5 Updated by Benni Mack over 4 years ago

  • Status changed from Accepted to Closed

Fixed in master!

Also available in: Atom PDF