Project

General

Profile

Actions

Feature #31096

closed

Epic #69347: EXT:form - Optimize form wizard

EXT:form - Recipient field may be undefined

Added by Oliver Hader over 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2011-10-19
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
hard
Sprint Focus:

Description

The recipient field of a form can by defined in the wizard. However the wizard can be saved and closed with keeping this setting undefined.
Result is a mail handling error in the frontend. The recipient field should be forced to be required in the form wizard.


Files

forge_31096.png (15.8 KB) forge_31096.png Oliver Hader, 2011-10-19 10:22
Actions #2

Updated by Oliver Hader over 12 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Steffen Ritter over 12 years ago

  • Complexity set to easy
Actions #4

Updated by Chris topher over 12 years ago

  • Target version changed from 4.6.0 to 4.6.1
Actions #5

Updated by Chris topher over 12 years ago

  • Target version changed from 4.6.1 to 4.6.2
Actions #6

Updated by Xavier Perseguers over 12 years ago

  • Target version deleted (4.6.2)
Actions #7

Updated by Alexander Opitz over 9 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

Actions #8

Updated by Frederic Gaus over 9 years ago

This is reproducible on current master.

Actions #9

Updated by Alexander Opitz almost 9 years ago

  • Status changed from Needs Feedback to New
Actions #10

Updated by Björn Jacob almost 9 years ago

  • Category changed from Form Framework to 1602
Actions #11

Updated by Björn Jacob almost 9 years ago

  • Category changed from 1602 to Form Framework
Actions #12

Updated by Björn Jacob almost 9 years ago

  • Parent task set to #69347
Actions #13

Updated by Björn Jacob over 8 years ago

  • Tracker changed from Bug to Feature
  • Target version set to 8 LTS

This is quite a huge task. Since we want to rewrite the form wizard I'm moving the ticket to version 8.

Actions #14

Updated by Björn Jacob over 8 years ago

  • Subject changed from Recipient field may be undefined to EXT:form - Recipient field may be undefined
  • Complexity changed from easy to hard
Actions #15

Updated by Björn Jacob over 8 years ago

  • Status changed from New to Closed
  • Target version deleted (8 LTS)
  • PHP Version deleted (5.3)

The form wizard will be rewritten in version 8. We will add this requirement to the roadmap. The current wizard will not be touched anymore.

Actions

Also available in: Atom PDF