Feature #31098

Epic #69347: EXT:form - Optimize form wizard

EXT:form - Reduce predefined form element fullname

Added by Oliver Hader about 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2011-10-19
Due date:
% Done:

20%

PHP Version:
5.3
Tags:
Complexity:
Sprint Focus:

Description

The predefined form element fullname shows additional fields like suffix, prefix, middle which shall be disabled by default.
The most common use case is to have firstname and lastname here.

forge_31098.png View (33.5 KB) Oliver Hader, 2011-10-19 10:30

TYPO3_Forms_[TYPO3_CMS_7.5.0-dev]_-_2015-08-28_14.11.11.png View (21.7 KB) Sebastian Wagner, 2015-08-28 14:12

History

#1 Updated by Oliver Hader about 8 years ago

see

#2 Updated by Chris topher about 8 years ago

  • Target version changed from 4.6.0 to 4.6.1

#3 Updated by Chris topher about 8 years ago

  • Target version changed from 4.6.1 to 4.6.2

#4 Updated by Xavier Perseguers almost 8 years ago

  • Target version deleted (4.6.2)

#5 Updated by Alexander Opitz almost 5 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#6 Updated by Riccardo De Contardi almost 5 years ago

Still present in 6.2.9

#7 Updated by Alexander Opitz almost 5 years ago

  • Status changed from Needs Feedback to New

#8 Updated by Bjoern Jacob over 4 years ago

  • Category changed from Form Framework to 1602

#9 Updated by Bjoern Jacob over 4 years ago

  • Category changed from 1602 to Form Framework

#10 Updated by Bjoern Jacob over 4 years ago

  • Tracker changed from Bug to Feature

I don't think that this is a bug. IMHO there should be a way to make this configurable or at least have the possibility to remove all the fields one does not need. We're thinking about a solution and like to discuss it here. Please stay tuned :)

#11 Updated by Bjoern Jacob over 4 years ago

  • Parent task set to #69347

#12 Updated by Bjoern Jacob over 4 years ago

  • Status changed from New to In Progress

#13 Updated by Sebastian Wagner over 4 years ago

  • Assignee set to Sebastian Wagner

#14 Updated by Sebastian Wagner over 4 years ago

We could easily switch prefix, middlename and suffix to disabled per default.
This arises an UX problem though:

Users won't recognize the switches to enable them again because they are hidden in the various-collapsible.
We'll try to refactor all properties into one collapsible or open the various-one as initially.

In order to nudge users about disabled prefix-fields we tried to just disable them, wich leads to them beeing hidden in the frontend as well.

--
In this context an other problem arose too:
properties in e.g. the various-collapsible only work for their respective elements whose function depends uppon their name.
This results in a property called "prefix" will ever only work in conjunction with (full)name-elements because we are missing at least one level of abstraction here.

In general there is to much logic placed within the ext-js-application.

#15 Updated by Bjoern Jacob about 4 years ago

  • Subject changed from Reduce predefined form element fullname to EXT:form - Reduce predefined form element fullname
  • Status changed from In Progress to New
  • Target version set to 8 LTS

#16 Updated by Bjoern Jacob almost 4 years ago

  • Status changed from New to Closed
  • Assignee deleted (Sebastian Wagner)
  • Target version deleted (8 LTS)

The form wizard will be rewritten in version 8. The current wizard will not be touched anymore. Right now, we don't see any use case for having such complex predefined elements in the future.

Also available in: Atom PDF