Bug #31290

Core uses deprecated functions

Added by Markus Klein almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2011-10-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

The just released Core 4.6 still uses deprecated functions internally:

t3lib_cache_backend_DbBackend->setCacheTable() - since TYPO3 4.6: The backend calculates the table name internally, this method does nothing anymore - require#55 // include#377 // t3lib_cache_Factory->create#2796 // t3lib_div::makeInstance#83 // ReflectionClass->newInstanceArgs#4924 // t3lib_cache_backend_AbstractBackend->__construct# // t3lib_cache_backend_DbBackend->setCacheTable#84 // t3lib_div::logDeprecatedFunction#379 (_src_4-6/t3lib/cache/backend/class.t3lib_cache_backend_dbbackend.php#378)
t3lib_cache_backend_DbBackend->setTagsTable() - since TYPO3 4.6: The backend calculates the table name internally, this method does nothing anymore - require#55 // include#377 // t3lib_cache_Factory->create#2796 // t3lib_div::makeInstance#83 // ReflectionClass->newInstanceArgs#4924 // t3lib_cache_backend_AbstractBackend->__construct# // t3lib_cache_backend_DbBackend->setTagsTable#84 // t3lib_div::logDeprecatedFunction#401 (_src_4-6/t3lib/cache/backend/class.t3lib_cache_backend_dbbackend.php#400)
tslib_fe->ADMCMD_preview() - since TYPO3 4.6, should be removed in TYPO3 4.8, this is now in Tx_Version - require#78 // tslib_fe->ADMCMD_preview#214 // t3lib_div::logDeprecatedFunction#1643 (_src_4-6/typo3/sysext/cms/tslib/class.tslib_fe.php#1642)

Related issues

Related to TYPO3 Core - Task #27931: Move workspace preview functionality into versioning / workspaceClosedBenni Mack2011-07-07

Actions
#1

Updated by Christian Kuhn almost 11 years ago

@Markus:
The first two lines are because you have own settings for TYPO3_CONF_VARS['cacheConfiguration'] in your localconf or in some ext_localconf. Your should clean this up (at least the tagsTable and cacheTable settings).

#2

Updated by Christian Kuhn almost 11 years ago

  • Complexity set to medium

The third line is a valid bug. It was introduced with issue #27931.

Benni Mack: Would you like to take a look?

#3

Updated by Markus Klein almost 11 years ago

Thx for the info Christian.

I'll take a look, but I guess tt_news may be responsible in this case.

I'll also try to find a way to improve the deprecationLog function, so that there's at least a chance for admins to see the caller of the deprecated function.

#4

Updated by Markus Klein almost 11 years ago

Confirmed for tt_news!

#5

Updated by Rupert Germann almost 11 years ago

thanks for diggin
I'll have a look.

#6

Updated by Markus Klein almost 11 years ago

The only call to tslib_fe->ADMCMD_preview() is in cms sysext, index_ts.php:214

#7

Updated by Chris topher almost 11 years ago

  • Target version changed from 4.6.0 to 4.6.1
#8

Updated by Markus Klein almost 11 years ago

Trace is even easier to read when using patch of #31300 (https://review.typo3.org/6343).

#9

Updated by Mr. Hudson almost 11 years ago

  • Status changed from New to Under Review

Patch set 1 of change I24152ecd3183a17257eb79a58f5270d0fce3a04d has been pushed to the review server.
It is available at http://review.typo3.org/6344

#10

Updated by Mr. Hudson almost 11 years ago

Patch set 2 of change I24152ecd3183a17257eb79a58f5270d0fce3a04d has been pushed to the review server.
It is available at http://review.typo3.org/6344

#11

Updated by Mr. Hudson almost 11 years ago

Patch set 3 of change I24152ecd3183a17257eb79a58f5270d0fce3a04d has been pushed to the review server.
It is available at http://review.typo3.org/6344

#12

Updated by Mr. Hudson almost 11 years ago

Patch set 1 of change I79c411f9028395e3b7e0eac4a605f7dc668160c3 has been pushed to the review server.
It is available at http://review.typo3.org/6648

#13

Updated by Markus Klein almost 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF