Project

General

Profile

Actions

Bug #31640

closed

TCA: IRRE Inline records + renderMode "tree" -> "Error 500, Internal Server Error"

Added by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2011-11-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am trying to use the new treeView (renderMode: "tree") in combination with IRRE Inline-Records feature.

I configured my records to have different fields enabled depending on a type-switch. The tree-Field is used for one of these TCA-Types.

The Error comes up while trying to open a closed IRRE-Item. The error only appears after closing the previously created item and closing the IRRE-Item. Then re-enter the LIST-Mode and try to open the IRRE-Item.

The error does NOT come up if...
  • the type-view does not include the tree-field!
  • the type-view for the treeView is rendered without having renderMode:tree enabled
    (it will be rendered as usual select-list)

I am trying to implement the feature in once of my new extensions for TYPO3. I could provide the pre-release code for re-production of the error.

Any help would be very great to finish the feature.

Best regards
Gabriel


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #27957: TCA tree somehow causes fatal error when using in inline record (IRRE)ClosedXavier Perseguers2011-07-07

Actions
Actions #1

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

I did some further research to find the reason for this error. So I traced the Errors on ajax.php:

This happens in the Javascript-Console (tested on Google-Chrome)

POST http://intern.typoworx.de/tx_dev/typo3/ajax.php 500 (Internal Server Error)
XHR finished loading: "http://intern.typoworx.de/tx_dev/typo3/ajax.php".

(Note: this response takes some seconds...)
XHR finished loading: "http://intern.typoworx.de/tx_dev/typo3/ajax.php?_dc=1320664678001&ajaxID=BackendLogin%3A%3AisTimedOut&skipSessionUpdate=1".

The last message is repeated continously with some pauses between it!

The response for Ajax contains the following:
(http://intern.typoworx.de/tx_dev/typo3/ajax.php?_dc=1320664678001&ajaxID=BackendLogin%3A%3AisTimedOut&skipSessionUpdate=1)

{"login":{"will_time_out":false}}

This looks like the AJAX-Request is going to believe my Login-Session in Backend is timing out?
But in fact I can work without problems in Backend.

Note: I was using EXT:disablebackendformprotection to avoid some bugging messages while working in TYPO3 BE-Forms. I disabled the extension to make shure it isn't causing the bug. But it still appears after disabling it.

Actions #2

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

We noticed the same problem on TYPO3 4.5.0 using EXT:powermail (also using IRRE). There also comes up the "Error 500" while trying to open Formular-Items of Powermail Form-Records. By the way - this is a different Debian-Server also using LAMP (Linux, Apache, PHP5).

Update (2):
I also tested to upgrade to TYPO3 4.6.0 (current stable) - no luck! The "Error 500" still keeps bugging me.

Actions #3

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

Does nobody have any idea how to fix this?

The problem still exits!

Actions #4

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

Does really nobody has any idea how this issue can be corrected? Probably any "Sponsoring" of this issue may help?

Actions #5

Updated by Joerg Kummer over 12 years ago

Found same problem: TYPO3v4.5.7
Field with TCA config 'select' inside an IRRE element worx fine. Use of renderMode 'tree' avoids opening for closed existing elements and creating new elements.

Attend by a sys-log entry:
Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1284906026: Language and character encoding are not set. | RuntimeException thrown in file /pathToMyTYPO3src/t3lib/class.t3lib_pagerenderer.php in line 1795

Which comes, during method includeLanguageFileForInline in t3lib_pagerenderer class, where file-reference is '../typo3/sysext/lang/locallang_csh_corebe.xml' and $selectionPrefix is 'tcatree' and $this->charSet is not set.

No solution found.

Actions #6

Updated by Adrien Crivelli over 12 years ago

I have similar error as described by Joerg Kummer with TYPO3 4.5.10 and PHP 5.3.6. Any hints or workarounds yet ?

Actions #7

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

Hello Adrien,
hello Joerg,

I'm sorry - I don't have a solution yet. I am also hoping for some feedback of the treeView-Developers.

The only way would be to avoid using treeView and IRRE-Records OR to use an alternative Function for the treeView.

I didn't find an alternative to treeView yet! Any recommendations or ideas?

Actions #8

Updated by Stefan Galinski over 12 years ago

A small demo extension can increase the chances that someone takes this bug and fixes it.

Actions #9

Updated by Gabriel Kaufmann / Typoworx NewMedia over 12 years ago

Hello,

I am using the IRRE + treeView Feature in one of my Extension. It is a FAQ-Extension.

http://typo3.org/extensions/repository/view/tnm_nicefaq/current/info/

Just install it and enter some dummy-records (1-2 parent category items containing 2 faq-items each). The error will occur while choosing the item-type "referenced item" within a category. This type is mentioned to reference to an existing item (f.e. duplicate between different categories within the FAQ). After saving such item once, the error should occur next time you try to open&edit this item.

Feedback for this extension is welcome.

Actions #10

Updated by Daniel Gercke about 12 years ago

Hello,

i have similar error as described by you with Typo3 4.5.13 an PHP 5.2.17 on live system but on my dev system Typo3 4.5.10 and php-fpm-5.3.10 the error is not reproducible.
I´ve checked the values in localconf.php but no difference.

Hope this help in further analysis.

Daniel

Actions #11

Updated by Xavier Perseguers almost 12 years ago

  • Status changed from New to Resolved
Actions #12

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF