Bug #31812

Localization failed; There already was a localization for this language of the record!

Added by Stefan Geith almost 9 years ago. Updated 8 months ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2011-11-15
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If - by accident - a (single) record got translated before its parent got translated, then the translation will never again be accessible from within IRRE.

Example:
Think of a Cities and Hotels. Hotels are Inline-Records within Cities.
If you translate a Hotel and later you want to translate the city, that contains this hotel, the error-message
"Localization failed; There already was a localization for this language of the record!"
is thrown.

So IRRE knows, that there is a translation, but because this translation does not have the correct relation, its not getting processed.
BUT: IRRE knows the relation of the (untranslated) default-records an could easily correct the relation to the already translated child-record - Right ?

The same problem occurs, if you translate using L10N-Mgr: All imported Irre-Child-Records dont have the correct relation to their parents and so will not be accessible via IRRE from their parent-records...


Related issues

Related to TYPO3 Core - Bug #84185: Errormessage 'Localization failed' with showSynchronizationLink (IRRE) New 2018-03-09

History

#1 Updated by Mr. Hudson almost 9 years ago

  • Status changed from New to Under Review

Patch set 1 of change I5253e992f94b1f9471872db25c0fe402b4551458 has been pushed to the review server.
It is available at http://review.typo3.org/6715

#2 Updated by Mr. Hudson almost 9 years ago

Patch set 2 of change I5253e992f94b1f9471872db25c0fe402b4551458 has been pushed to the review server.
It is available at http://review.typo3.org/6715

#3 Updated by Mr. Jenkins almost 9 years ago

Patch set 3 of change I5253e992f94b1f9471872db25c0fe402b4551458 has been pushed to the review server.
It is available at http://review.typo3.org/6715

#4 Updated by Mr. Jenkins almost 9 years ago

Patch set 4 of change I5253e992f94b1f9471872db25c0fe402b4551458 has been pushed to the review server.
It is available at http://review.typo3.org/6715

#5 Updated by Gerrit Code Review almost 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6715

#6 Updated by Alexander Opitz over 7 years ago

Hi Stefan,

is this patch still relevant? If yes, can you rebase the patch to current master?

#7 Updated by Stefan Geith over 7 years ago

Hi Alexander,

This Problem is still in 4.5 and 4.7 - patch is for 4.5 and I use it in every Installation.
Rebase to current master is a problem - I don't use 6.x atm and do not have a dev-setup for 6.x at the moment.
I will even have to test, if this is still not solved in 6.x ...

#8 Updated by Tobias H. over 6 years ago

Hi,

it is still relevant. We got the problem with the l10nmgr and TYPO3 6.1.6. All translated image elements have no correct irre relation to the FAL.

Best Regards,
tobias

#9 Updated by Maik Peuser over 6 years ago

Hi,

we could get it running with a modified version (TYPO3 6.17). We replaced all old t3lib_div calls and the testInt call. So far most of it for im/export via backend works, but anything with fal-relations isn't translated correctly. the fal relations are broken and you cannot those relations in backend.

Question is if this is core related or maybe only in the extension ?eat =)

Best Regards,
Maik

#10 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/6715

#11 Updated by Gerrit Code Review over 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/6715

#12 Updated by Gerrit Code Review about 5 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/6715

#13 Updated by Gerrit Code Review about 5 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/6715

#14 Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Under Review to New
  • TYPO3 Version changed from 4.5 to 7
  • PHP Version changed from 5.2 to 5.5
  • Is Regression set to No

Patch has been abandoned - set it back to "new".

#15 Updated by Kevin Ditscheid over 1 year ago

I think this issue is not relevant anymore for TYPO3 9, because the DataHandler localization has been changed

#16 Updated by Benni Mack over 1 year ago

  • Status changed from New to Closed

Closing as suggested, cannot reproduce myself either.

#17 Updated by Raphaël Splivalo Splivalo 9 months ago

  • Priority changed from Should have to -- undefined --
  • TYPO3 Version changed from 7 to 9
  • PHP Version changed from 5.5 to 7.3

Sorry to re-open this issue.

We have TYPO3 9.5.13 on some websites and we have that problem.
When we try to translate a page we have that warning "There already was a localization for this language of the record", when we look at the pages table in DB the page record have a correct l10n_source but no id in the l10n_parent column.
We have that errors with migrated TYPO3 (V7 to V9 or V8 to V9).

Thanks for your help
Best regards,
Raf

#18 Updated by Christian Oettinger 8 months ago

Hi all,

I had the same issue (warning "There already was a localization for this language of the record" when trying to create a translation).
In my case a BE user was trying to create a translation of a page while the field
Transl.Orig (l10n_parent) [pages:l10n_parent]
was not set as editable in Access List of the appropriate BE user group.
So the translation was created but "l10n_parent" had value 0, which led to the problem in my case.

Have a great day!
oe

#19 Updated by Susanne Moog 7 months ago

  • Related to Bug #84185: Errormessage 'Localization failed' with showSynchronizationLink (IRRE) added

Also available in: Atom PDF