Bug #31996

Workspace preview does not transfer query parameters

Added by Francois Suter about 9 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-11-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the URL called up when previewing from the TYPO3 backend contains additional query parameters, these should be passed on to the URLs of the iframe panels of the preview view.

I have no scenario from the Core to repeat this, but I was in a situation where I manually added query parameters to the URL and was surprised to find them being ignored. This is why I'm not submitting this patch outright, but rather just uploading it here for discussion.

Incidentally this patch resolves a "todo" that was mentioned inside the PreviewController about the language parameter not always being "L". With this patch all non-workspaces related GET query parameters are retrieved, so there's no worrying about which should be the language parameter.


Files


Related issues

Related to TYPO3 Core - Bug #19377: Versioning Preview: records that require a singlePid don't work (eg tt_news)Closed2008-09-25

Actions
#1

Updated by Tolleiv Nietsch almost 9 years ago

  • Status changed from New to Accepted

Patch looks fine for me - would you mind sending it to Gerrit?

#2

Updated by Michael Voehringer almost 9 years ago

+1 for this Patch.

#3

Updated by Ernesto Baschny over 8 years ago

  • Target version deleted (4.5.9)

Not really targetted to any release yet, keep up the discussion. :)

#4

Updated by Francois Suter about 8 years ago

I'll get back to that one, I found a scenario where it happens. The target version can be reset to the next TYPO3 4.5 release, please.

#5

Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15680

#6

Updated by Francois Suter about 8 years ago

How to test simply:

  1. preview any page from a workspace
  2. go to your browser's address bar and add "&foo=bar" to the URL
  3. check the frames info: the "&foo=bar" parameter does not appear
  4. apply the patch and repeat the process, "&foo=bar" should be visible in both (live and workspace) frames URLs

For the record, my real-world use case is with Tesseract's displaycontroller preview function, where some parameters are passed in particular to trigger a preview of hidden elements. Since I doubt anyone has such a setup available, the above test case does fine instead.

#7

Updated by Francois Suter about 8 years ago

I just realized that looking at the frame info is misleading. A better way to test is to really print out the GET var "foo" in the page and observe its absence/presence.

#8

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch workspaces_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15704

#9

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/21111

#10

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21112

#11

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21112

#12

Updated by Francois Suter about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Michael Stucki almost 7 years ago

  • Category set to Workspaces
#14

Updated by Michael Stucki almost 7 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#15

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF