Bug #32703

HTMLArea RTE is broken in 4.5.9 using IE8

Added by Lars Houmark almost 10 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2011-12-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The editor new stops trying to load in IE8 (and myabe other IE variants, have not tested yet).

After doing initial debugging it seems only one file is changed between 4.5.8 and 4.5.9:
typo3/sysext/rtehtmlarea/class.tx_rtehtmlarea_base.php

At this point, I am not sure of the precise reason for the braking changes in IE, but overwriting the file in 4.5.9 with the file from 4.5.8 makes the editor load again.


Related issues

Is duplicate of TYPO3 Core - Bug #32625: Custom RTE-styles brokenClosedStanislas Rolland2011-12-16

Actions
#1

Updated by Stanislas Rolland almost 10 years ago

Please test this change: http://review.typo3.org/7341

#2

Updated by Lars Houmark almost 10 years ago

That seems to do it.

Successfully tested on 4.5.9. Working again in IE8.

Thanks!

#3

Updated by Steffen Ritter almost 10 years ago

  • Status changed from New to Rejected
  • Priority changed from Should have to Won't have this time

duplicate of regression

#4

Updated by Stanislas Rolland almost 10 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Status changed from Rejected to Resolved
  • Assignee set to Stanislas Rolland
  • Priority changed from Won't have this time to Must have
  • Target version set to 4.5.10
  • PHP Version set to 5.3
#5

Updated by Riccardo De Contardi about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF