Bug #32709

Make FileBackend more stable

Added by Daniel Poetzinger almost 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2011-12-21
Due date:
2011-12-21
% Done:

0%

Estimated time:
2.00 h
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

see also FLOW3 Issue #32707

Problem is that the set function is not atomar.
The attached Patch should fix it


Files

32707_filebackend-not-atomar.diff (1.57 KB) 32707_filebackend-not-atomar.diff Daniel Poetzinger, 2011-12-19 21:52

Related issues

Follows (1 day) TYPO3.Flow - Bug #32707: Bad Bad FileBackendAcceptedKarsten Dambekalns2011-12-19

Actions
#1

Updated by Oliver Hader almost 10 years ago

  • Category set to Caching
  • PHP Version set to 5.3
  • Complexity changed from easy to medium

Once it was accepted for FLOW3 we can consider of backporting it (taking your solution).

#2

Updated by Michael Klapper almost 10 years ago

Seems to be related on this issue #31460 and https://review.typo3.org/#change,7504

#3

Updated by Alexander Opitz almost 7 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#4

Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF