Bug #32775

Date-Picker does not hide in IRRE Elements

Added by Andreas Dörler about 8 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2011-12-22
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

if there are datetime fields within IRRE (e.g. datetime field in powermail or any datetime field in a custom extension) the datepicker stays open if one clicks the calendar more than once.

  • Open a IRRE Element which contains a datetime field
  • Click calendar icon => datepicker pops up
  • Click to an area outside => closes the datepicker
  • Click calendar icon again => datepicker opens up again
  • Click to an area outside or select a date => datepicker remains open and cannot be closed anymore

If there are more than one datetime field multiple datepickers will stay open.

There is no JavaScript error => Testet with Firefox 8.0 and Typo3 4.5.8

FYI: One year ago there was another issue with datepicker in IRRE, see #22796.

Kind regards,
Andreas

History

#1 Updated by Steffen Gebert about 8 years ago

  • Status changed from New to Accepted

Thanks for your report, Andreas! I can confirm this issue.

Do you have a solution for that issue? I'm not a JS guru and have no time ATM.

Steffen

#2 Updated by Andreas Dörler almost 8 years ago

Hello Steffen,

Steffen Gebert wrote:

Do you have a solution for that issue? I'm not a JS guru and have no time ATM.

Unfortunately not. I digged a little bit through the JS-Code, but as there are so many JS-Files loaded in the Backend and no obvious JS-error is thrown I do not really know where to start debugging.

It would be great if someone who is familiar with the date pickers code could throw an eye on this issue.

Andreas

#3 Updated by Andreas Kiessling about 7 years ago

Seems to be fixed with #23843 which removes the event from the datepicker before adding them (again). I had the same issue a while ago, but could not reproduce them now anymore.

datepicker.removeAllListeners();
datepicker.on('click', function(){
    menu.show(datepicker);
});

Shouldn't such events be delegated to the form or body element, instead of being constantly removed and added?

#4 Updated by Andreas Dörler over 6 years ago

Andreas Kiessling wrote:

Seems to be fixed with #23843 which removes the event from the datepicker before adding them (again). I had the same issue a while ago, but could not reproduce them now anymore.
[...]

Shouldn't such events be delegated to the form or body element, instead of being constantly removed and added?

Hi Andreas,

I've just tried in a 4.5.25 installation. datepicker.removeALLListeners(); is included in this version, but the problem still exists.
The datepicker closes only the very first time (either by selecting a date or by clicking outside).

Andreas

#5 Updated by Mathias Schreiber about 5 years ago

  • Category set to 978
  • Assignee set to Benni Mack
  • Is Regression set to No

Benni, will this be fixed with the new datepicker?

#6 Updated by Mathias Schreiber almost 5 years ago

  • Status changed from Accepted to Resolved

fixed on master

#7 Updated by Andreas Dörler almost 5 years ago

Hi Mathias,

Mathias Schreiber wrote:

fixed on master

this is good to hear.
Could you provide a link to the commit on github? I'd like to check if it's possible to backport the patch to TYPO3 CMS 4.5.

Thank you
Andreas

#9 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF