Bug #33866

show uid of reference in show_item.php

Added by Joh. Feustel about 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-08-04
Due date:
2012-08-04
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In #29774 the "References to this item" table was changed to show the actual title of the referenced record. Now the uid is not shown anymore and if there are more items with same title there is no easy way to identify the record in the backend.

Solution is to just add the uid and pid in the title attribute of the record title.

33866.diff View (1.34 KB) Joh. Feustel, 2012-02-12 14:15


Related issues

Related to TYPO3 Core - Feature #33808: Make record references expandable and clickable Closed 2012-02-09
Related to TYPO3 Core - Task #29774: Improve information in show_item.php Closed 2011-09-14

Associated revisions

Revision 29f59041 (diff)
Added by Joh. Feustel about 8 years ago

[BUGFIX] show uid of reference in show_item.php

The uid of referenced records is not shown anymore and if there are
more items with same title, there is no easy way to identify the
record in the backend.

Solution is to add a column for the uid and page information in the
title attribute of the uid.

Change-Id: I90c44cbff7840888c397d6667ae0a8efa0f5d0a7
Fixes: #33866
Releases: 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/8992
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Thorsten Kahler
Tested-by: Thorsten Kahler

Revision 44ec00ba (diff)
Added by Joh. Feustel almost 8 years ago

[BUGFIX] show uid of reference in show_item.php

The uid of referenced records is not shown anymore and if there are
more items with same title, there is no easy way to identify the
record in the backend.

Solution is to add a column for the uid and page information in the
title attribute of the uid.

Change-Id: I998a87cac7c01df50b8bc884794b0418e967a191
Fixes: #33866
Releases: 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/9005
Reviewed-by: Sebastian Fischer
Reviewed-by: Georg Ringer
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

History

#1 Updated by Joh. Feustel about 8 years ago

Just wrapped in a span tag and added uid and pid as title attribute. This is applied also for the table title since if the record title is long getRecordTitle() crops it and returns the full title also in a span with title attribute. Therefore the browser would show this title and not the uid in the tooltip.

#2 Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#3 Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#4 Updated by Thorsten Kahler about 8 years ago

  • Status changed from Under Review to Accepted

Adding the same information twice is not a valid solution. And hiding the information in title attribute either.

#5 Updated by Joh. Feustel about 8 years ago

Having the id in the tooltip looks like a common solution for me in the backend. Its there in the pagetree and in the list module.
The idea of addig it to the table title also was to have it available if records title has its own tooltip. While it looks important to still have it on the record title for default case.
Would you reintroduce the uid column instead?
I think this should happen in #33808 later.

#6 Updated by Markus Klein about 8 years ago

Thorsten, can you please leave this on "Under Review" and post your comments in gerrit!

#7 Updated by Thorsten Kahler about 8 years ago

Markus Klein wrote:

Thorsten, can you please leave this on "Under Review" and post your comments in gerrit!

IMHO this is the place to discuss the bug and the (approach to the) solution. If I have to say something about the code you'll find it in Gerrit for sure.

#8 Updated by Thorsten Kahler about 8 years ago

  • Category set to Backend User Interface

Joh. Feustel wrote:

Having the id in the tooltip looks like a common solution for me in the backend. Its there in the pagetree and in the list module.

Yes, and in both cases there are ways to show the uid directly (TSconfig in pagetree and column selection in list module).

The idea of adding it to the table title also was to have it available if records title has its own tooltip. While it looks important to still have it on the record title for default case.

The reasons you gave in comment 1 were already clear enough :) But doing things twice is a well-known anti-pattern.

Would you reintroduce the uid column instead?
I think this should happen in #33808 later.

I think the uid column should be reintroduced, yes. And in #33808 I could imagine to add a linked info icon, which opens yet another instance of the "View Item" popup. But that decision is up to the UX/UI team and I fear we won't get that in before feature freeze today (there already are outstanding feature requests).

I'd drop the "sorting" column in favour of uid, because that don't add any useful information here (at least, that's what occurs to me).

#9 Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#10 Updated by Gerrit Code Review about 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#11 Updated by Markus Klein about 8 years ago

Thorsten Kahler wrote:

Markus Klein wrote:

Thorsten, can you please leave this on "Under Review" and post your comments in gerrit!

IMHO this is the place to discuss the bug and the (approach to the) solution. If I have to say something about the code you'll find it in Gerrit for sure.

I agree, but still I feel it's not right to set a ticket back to "Accepted" when a patch is filed to gerrit.

Nevertheless, I'll review your patch now.

#12 Updated by Gerrit Code Review about 8 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#13 Updated by Gerrit Code Review about 8 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#14 Updated by Gerrit Code Review about 8 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#15 Updated by Gerrit Code Review about 8 years ago

Patch set 8 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8992

#16 Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9005

#17 Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9005

#18 Updated by Joh. Feustel about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9358

#20 Updated by Wouter Wolters over 7 years ago

This ticket can be closed, all affected branches are up to date. Except 4.5 which this patch does not apply. See http://www.typo3-anbieter.de/typo3-merges/core.html and look for 33866

#21 Updated by Stefan Galinski over 7 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF