Bug #34686

style fix for install tool phpinfo

Added by Markus Timtner over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-03-09
Due date:
% Done:

100%

Estimated time:
0.10 h
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The install tool stylesheet overrides some styles of phpinfo, see screenshots.

fix:

in: typo3/sysext/install/Resources/Public/Stylesheets/install.css

add
body.standalone
to line 298 and 309, so that the selector reads
body.standalone .phpinfo h1
instead of
.phpinfo h1

This style bug has been around since forever.

before.png View - before (52.3 KB) Markus Timtner, 2012-03-09 13:05

after.png View - after (55.5 KB) Markus Timtner, 2012-03-09 13:05

install-tool-phpinfo.png View (64.6 KB) Philipp Gampe, 2012-04-27 14:19

Associated revisions

Revision 6290ccb8 (diff)
Added by Tomita Militaru over 7 years ago

[BUGFIX] Show phpinfo() header title

This is a no-brainer, fixes the bug with the title of
phpinfo() in the Install Tool being hidden from CSS.

Change-Id: Ia4ff710c24ae4b2537f0cbcdf154b62cce080784
Fixes: #34686
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10793
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 772a20e4 (diff)
Added by Tomita Militaru over 7 years ago

[BUGFIX] Show phpinfo() header title

This is a no-brainer, fixes the bug with the title of
phpinfo() in the Install Tool being hidden from CSS.

Change-Id: If33a836a606b9c861cbf897a518bd68ed9118d3f
Fixes: #34686
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10847
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 5fe7a23b (diff)
Added by Tomita Militaru over 7 years ago

[BUGFIX] Show phpinfo() header title

This is a no-brainer, fixes the bug with the title of
phpinfo() in the Install Tool being hidden from CSS.

Change-Id: I7b4e1a9f30b88a4758516502cf6c816e96763890
Fixes: #34686
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10846
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision baa87a34 (diff)
Added by Tomita Militaru over 7 years ago

[BUGFIX] Show phpinfo() header title

This is a no-brainer, fixes the bug with the title of
phpinfo() in the Install Tool being hidden from CSS.

Change-Id: I023beb22badbdef9c747b6d2d2e686449d71053a
Fixes: #34686
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10845
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 02cc0e7b (diff)
Added by Tomita Militaru over 7 years ago

[BUGFIX] Show phpinfo() header title

This is a no-brainer, fixes the bug with the title of
phpinfo() in the Install Tool being hidden from CSS.

Change-Id: Ia4ff710c24ae4b2537f0cbcdf154b62cce080784
Fixes: #34686
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10793
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Markus Timtner over 7 years ago

screenshots got lost, here they are:

#2 Updated by Markus Timtner over 7 years ago

due to the difference of install tool only and install tool via backend,
one needs to add

display:block;
to the mentioned selectors.

#3 Updated by Jigal van Hemert over 7 years ago

  • Status changed from New to Accepted

Can you prepare a patch for this?

If you need information on how to contribute, you can find tutorials at:
http://wiki.typo3.org/Contribution_Walkthrough_Tutorials

#4 Updated by Jigal van Hemert over 7 years ago

  • Category changed from Frontend to Backend User Interface

#5 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/10793

#6 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/10793

#7 Updated by Philipp Gampe over 7 years ago

I looks much different for me (no purple style for me). So I can not really reproduce that.

OK, found it ... one must scroll down :)

#8 Updated by Tomita Militaru over 7 years ago

Philipp Gampe wrote:

I looks much different for me (no purple style for me). So I can not really reproduce that.

Please scroll on that page down and you will see the purple part from that screenshot.

#9 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/10793

#10 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/10845

#11 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/10846

#12 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/10847

#13 Updated by Tomita Militaru over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/13118

#15 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13240

#16 Updated by Wouter Wolters about 7 years ago

Please close this issue. All affected branches are up to date.

#17 Updated by Stefan Galinski about 7 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF